Bug 149857 - ftp proxy in squid broken as of squid 2.5STABLE7-1
ftp proxy in squid broken as of squid 2.5STABLE7-1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 08:13 EST by William Emmanuel S. Yu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-12 10:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Emmanuel S. Yu 2005-02-28 08:13:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:

i set my machines to automatically upgrade to the latest and the
greatest packages via yum. one day FTP proxy support over squid ceased
to function. i am using squid-2.5STABLE7-1 in FC2. i tried upgrading
to squid-2.5STABLE8-1 but the problem persists. i tried rolling back
to squid-2.5STABLE5-4 and it works again. 

Version-Release number of selected component (if applicable):
squid-2.5STABLE7-1

How reproducible:
Always

Steps to Reproduce:
1. install squid-2.5STABLE7-1 or higher in FC2
2. restart squid
3. try accessing an FTP site using squid as a proxy (Filezilla)
    

Actual Results:  files uploaded and downloaded will not completed

Expected Results:  files uploaded and downloaded should completed

Additional info:

swimming through the SQUID diffs. the only glaring change between
STABLE5 and STABLE7 is the replacement of all the clientReadBody()
with requestReadBody() in ftp.c.

-    clientReadBody(ftpState->request, ftpState->data.buf,
ftpState->data.size, ftpRequestBody, ftpState);
+    requestReadBody(ftpState->request, ftpState->data.buf,
ftpState->data.size, ftpRequestBody, ftpState);

this change came with the WCCP updates. i am not sure it is related.
Comment 1 Matthew Miller 2005-04-26 11:44:49 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 2 Martin Stransky 2005-06-30 08:09:32 EDT
Could you please test latest FC4 package? I have tried to reproduce it
but without success.
Comment 3 Martin Stransky 2005-07-12 10:15:48 EDT
Please, reopen it if you still have this problem. I can't reproduce it.

Note You need to log in before you can comment on or make changes to this bug.