Bug 149872 - term locks on tab completion of ~<dirname>
term locks on tab completion of ~<dirname>
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 10:36 EST by Ron Carver
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 10:30:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Carver 2005-02-28 10:36:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Term locks on tab completion of ~ directories.  I have tried this in 
bash, tcsh, and zsh.  it locks every time.  

Version-Release number of selected component (if applicable):
xterm-192-1

How reproducible:
Always

Steps to Reproduce:
1.open terminal window
2.type in ls ~rcar<tab>
3.it will not complete the dir name, if you hit tab again the term 
locks for 3-5 minutes.
    

Actual Results:  Locks terminal

Expected Results:  It should complete the <HOMEDIR> name of the person

Additional info:
Comment 1 Mike A. Harris 2005-03-06 11:49:47 EST
Is the directory you're doing this in within an NFS mount?

Does your system use LDAP or NIS for username lookups?

Does this problem happen in other directories as well, including
both local and remote filesystems?

Please provide an strace of both xterm and the shell you're using
as gzipped file attachments.

Comment 2 Mike A. Harris 2005-03-06 11:54:44 EST
Setting status to "NEEDINFO", awaiting response to above questions,
and strace of shell and xterm leading up to the problem.
Comment 3 Ron Carver 2005-03-07 09:06:52 EST
Yes the home directories are over an NFS mount.

Yes our system uses LDAP for authentication

No, it does not do it on other directories either local or remote.  I
can tab complete the home directories if I do the full directory.. for
example "ls -la /people/rca<TAB> will get me /people/rcarver

I have not used strace before.  all I need to do is run strace xterm
>filename?  if not please provide more info on strace.
Comment 4 Mike A. Harris 2005-03-07 10:28:49 EST
This is most likely an NFS issue then, and unlikely to be a bug
in xterm.  I strongly suspected an NFS timout issue or similar
because nobody else has reported such an issue, and I'm unable
to reproduce it locally.

I suggest that you troubleshoot your NFS/LDAP setup, because it is
most likely the cause of the problem.  You can use tcpdump
and strace/ltrace to troubleshoot the issue.  If you require
assistance, you can subscribe to the fedora-list@redhat.com
mailing list and post a message about the problem.

For information on using tcpdump, strace, and ltrace, please consult
the manual pages and other documentation included with the OS.

Comment 5 Mike A. Harris 2005-03-07 10:30:22 EST
Setting status to NOTABUG (configuration or local technical problem,
not a bug.)

Note You need to log in before you can comment on or make changes to this bug.