Bug 149878 - Fence Properties display does not update when fence properties are changed
Fence Properties display does not update when fence properties are changed
Status: CLOSED DUPLICATE of bug 140674
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 11:03 EST by Paul Kennedy
Modified: 2015-04-19 20:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 13:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Kennedy 2005-02-28 11:03:56 EST
Description of problem:

After  changing  values in the Fence Properties dialog box, the
updated values are not displayed in the “Properties” display. Updated
properties are displayed when clicking the fence device. Also, after
updating "Node Properties", clicking either "Edit Node Properties",
"Manage Fencing For This Node" or "Delete Node" causes traceback errors. 

Version-Release number of selected component (if applicable):
system-config-cluster-0.9.5-1.0

Steps to Reproduce:
1.  Navigate: Cluster -> Cluster Nodes -> foo -> Manage Fencing
    For This Node
2.  At the Fence Configuration dialog box, click "foo", then click
    "Add a New Fence Level" 
3.  At the Fence Configuration dialog box, click "Fence-Level-1",
    then "Add a New Fence to this Level".
4.  At the Fence Properties dialog box, enter information. For
    example, for a power switch, enter "Port" and "Switch"
    parameters. Click "OK".
5.  At the Fence Configuration dialog box, click "Close".
6.  Observe at the "Properties" box at the upper right; "Fence
    Status" has not changed. 
7.  Click "Edit Node Properties" and click "OK".
8.  Observe under Cluster Nodes, "foo" is no longer highlighted.
9.  Click either "Edit Node Properties", "Manage Fencing For This
    Node" or "Delete Node". 
10. Observe traceback error.

-------------------------
Traceback error messages
-------------------------

For "Edit Node Properties":
-----------------------------
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line
708, in on_clusternode_edit_b
    self.prep_clusternode_edit_dialog(NODE_EXISTING)
  File "/usr/share/system-config-cluster/ConfigTabController.py", line
731, in prep_clusternode_edit_dialog
    nd = model.get_value(iter, OBJ_COL)
TypeError: iter must be a GtkTreeIter


For "Manage Fencing For This Node":
------------------------------------
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line
338, in on_clusternode_fence_b
    treetype = model.get_value(iter, TYPE_COL)
TypeError: iter must be a GtkTreeIter


For "Delete Node": 
-------------------
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line
714, in on_clusternode_delete_b
    nd = model.get_value(iter,OBJ_COL)
TypeError: iter must be a GtkTreeIter


Actual results:
For step 6, "Properties" does not change.
For step 10, the node "foo" became deselected (not highlighted), not
allowing further configuration of that node through the "Edit Node
Properties", "Manage Fencing For This Node" or "Delete Node" buttons.

Expected results:
For step 6, "Properties" display should change to reflect changes made. 
For step 10, the node "foo" should have stayed highlighted, allowing
clicking of "Edit Node Properties", "Manage Fencing For This Node" or
"Delete Node" without traceback errors.

Additional info:

May be related to problem in 149674.
Comment 1 Jim Parsons 2005-03-01 13:19:44 EST

*** This bug has been marked as a duplicate of 140674 ***

Note You need to log in before you can comment on or make changes to this bug.