Bug 149881 - Booting Rawhide as of 2005/02/25 fails on Mac Mini
Booting Rawhide as of 2005/02/25 fails on Mac Mini
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 11:11 EST by Philipp Ott
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 17:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
various logs and infos from mac mini (28.72 KB, application/octet-stream)
2005-03-11 04:30 EST, Philipp Ott
no flags Details

  None (edit)
Description Philipp Ott 2005-02-28 11:11:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
I installed the
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/
tree (as of 2005/02/25) on a standard Mac Mini (256mb, 40gb hd) and
ran across some problems.

1) Booting graphics mode only shows 640x480 pixels, top/left, which
isnt enough for the graphics installation because the buttons arent
visible

Then I used linux text at the boot prompt and installed a Workstation
setup without visible any problems.

Upon finish I used an alternate console to edit /etc/inittab to enter
runlevel 3 instead of 5

2) Booting the installed OS hard freezes the Mac Mini at some time

3) rgba shows always up even when I enter linux text again on the boot
prompt

4) yaboot shows no Mac OSX option :-(

5) again the graphic boot progress shows only 640x480, top/left

6) "press I for single step" during boot doenst work, so I can not say
which rc-scripts is responsible for the hardcrash. Sometimes booting
runs though the graphic boot and then the screen turns gray blank, the
mouse is moveable for a few seconds before the Mac Mini freezes. Other
times the Mac Mini freezes while starting CUPS or other later
services. Capslock on keyboard doesnt work.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. installing .../development/ppc/ via NFS on a Mac Mini and ppc/boot.iso

2. boot using linux text, graphics mode only shows 640x480

3. booting installed OS hard freezes Mac Mini at some time, so far
always before firstboot came up

Expected Results:  A booting and working Mac Mini.

A Mac OS X boot option in yaboot.


Additional info:
Comment 1 Bill Nottingham 2005-02-28 15:22:28 EST
Assigning to rhpl for the moment for the X issues.
Comment 2 Paul Nasrat 2005-03-02 12:53:48 EST
Please note it really helps to have seperate bugs for seperate issues.  Please
open a seperate bug for no OS X option - this is known but may not be in
bugzilla check the fedora ppc tracker:

https://bugzilla.redhat.com/beta/show_bug.cgi?id=fedora-ppc
https://bugzilla.redhat.com/beta/showdependencytree.cgi?id=fedora-ppc

What monitor do you have attached to the mini.  What is the output of kudzu -p
-b ddc as root.

We're looking at getting better video info out of OF which should help, but that
may not be in test1.
Comment 3 Colin Charles 2005-03-07 22:20:47 EST
Try to address some quick issues for the original bug reporter.

2) where does it hard freeze?

4) thats known. You need to edit /etc/yaboot.conf and add the macosx=/dev/hdaX
bit yourself

Comment 4 Philipp Ott 2005-03-10 04:14:43 EST
2) did freeze usually after cups was startet, sometimes still while in the
graphics boot progress, then later when the X server came up for firstboot..

rgba still shows just 640x480 during boot.

I ran yum -y update almost daily and since 4, 5 days it wasnt freezing anymore,
however X & firstboot etc. still dont work. The mouse appears and I can move it
forever and a day, but nothing else happens. firstboot doesnt show any infos,
just blank screen.

3) yes i did this and ran ybin and this problem was solved.

kudzu crashed with segmentation fault, with out without the -p -b ddc parameters.

Unfortunately I have to return the Mac Mini soon but I will dump here the
/etc/sysconfig/hwinfo, lspci, current rpm list and the X output.
Comment 5 Philipp Ott 2005-03-11 04:30:52 EST
Created attachment 111879 [details]
various logs and infos from mac mini
Comment 6 Colin Charles 2005-05-16 08:47:16 EDT
philipp, can you please retest for FC4t3? Most of this seems fixed with the release.
Comment 7 Paul Nasrat 2005-09-27 17:17:29 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.

Note You need to log in before you can comment on or make changes to this bug.