Bug 149887 - Copying large files with scp fails because of e1000 driver
Copying large files with scp fails because of e1000 driver
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 164942 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 11:53 EST by Davide Bolcioni
Modified: 2015-01-04 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-27 23:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2005-02-28 11:53:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
When copying a large file (350 MB) with scp, I got strange errors including "corrupted MAC on input". Looking up this error in Google it seemed related to the driver for Intel NICs in 2.6.10 kernels, see for example

 http://www.derkeiler.com/Mailing-Lists/securityfocus/Secure_Shell/2004-01/0004.html

More googling suggested as a workaround

  ethtool -K eth0 rx off tx off

which apparently worked.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Setup a host with a e1000 NIC
2. Try to copy a 350 MB file to said host
3. Observe errors 
  

Actual Results:  Various scp errors, mostly "broken pipe" and "corrupt MAC on input".

Expected Results:  Successful file transfer.

Additional info:

The network is a 100 MB switched network and the NIC autoconfigured for full duplex 100 MB. Interactive ssh sessions work fine; this was likely to be the first time I attempted to transfer a large file to this host over the LAN so I have no clue as to when the problem might have begun. In the past the same host was used to download ISO images from Internet; this transfer was over the LAN, so it seems that transfer speed might make a difference.
Comment 1 Dave Jones 2005-07-15 16:22:08 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Phil Oester 2005-08-16 20:01:42 EDT
I am experiencing this problem with FC4, and can confirm that this command:

ethtool -K eth0 rx off tx off

on both sender and receiver does solve it.  I actually submitted a new bug for 
this (bug 164942) as I originally assumed it was a bug with scp/ssh.  

I have experienced the bug in the FC4 kernels, as well as 2.6.1[23] kernels.

(tried to change version to FC4, but wouldn't let me...)
Comment 3 Davide Bolcioni 2005-08-17 03:43:48 EDT
Still happens with FC4 as per report above.
Comment 4 Tomas Mraz 2005-08-17 04:04:02 EDT
*** Bug 164942 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2005-11-10 15:04:03 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 6 Dave Jones 2005-12-27 23:42:55 EST
This bug has been mass-closed along with other bugs that have been in NEEDINFO
state for several months.

Due to the large volume of inactive bugs in bugzilla, this is the only method we
have of cleaning out stale bug reports where the reporter has disappeared.

If you can reproduce this bug after installing all the current updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting it be reopened,
and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.