Bug 1498875 - dnf system-upgrade reboot reboots twice without upgrading
dnf system-upgrade reboot reboots twice without upgrading
Status: CLOSED DUPLICATE of bug 1498207
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-05 09:13 EDT by Miro Hrončok
Modified: 2017-10-10 22:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-10 22:22:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log (5.66 MB, text/plain)
2017-10-05 10:57 EDT, Miro Hrončok
no flags Details
journalctl log (1.95 MB, application/octet-stream)
2017-10-05 11:03 EDT, Miro Hrončok
no flags Details
dnf.log (219.60 KB, text/x-vhdl)
2017-10-06 17:25 EDT, LiZhenbo
no flags Details
Comment4_dnf.log (6.43 MB, text/plain)
2017-10-06 17:52 EDT, LiZhenbo
no flags Details
Comment4_journalctl (3.60 MB, text/plain)
2017-10-06 17:54 EDT, LiZhenbo
no flags Details
log of the system-upgrade in dnf (2.02 MB, text/plain)
2017-10-09 07:05 EDT, hugotrip
no flags Details
Log of the reboot (journalctl -b ...) part of the system-upgrade (135.93 KB, text/x-vhdl)
2017-10-09 07:13 EDT, hugotrip
no flags Details

  None (edit)
Description Miro Hrončok 2017-10-05 09:13:55 EDT
Description of problem:
I'm following https://fedoraproject.org/wiki/DNF_system_upgrade to upgrade to Fedora 27. When i run `dnf system-upgrade reboot`, my computer reboots twice and I'm back to my desktop, no upgrade is happening.

Version-Release number of selected component (if applicable):
python3-dnf-plugin-system-upgrade-2.0.3-1.fc26.noarch


How reproducible: all the time


Steps to Reproduce:
1. follow https://fedoraproject.org/wiki/DNF_system_upgrade
2. do dnf system-upgrade reboot

Actual results:
reboots twice, back to desktop

Expected results:
reboots to a upgrade session

Additional info:


Videos here:

[I haven't realized how dirty the screen is until I made those, sorry about that.]

https://www.youtube.com/watch?v=cQ5Qb64k1aM

(video gets interrupted here (no space left on my SD card), but nothing fancy happens, just bios -> grub)

https://www.youtube.com/watch?v=Xkqhh5QbOoo
Comment 1 Jaroslav Mracek 2017-10-05 09:51:51 EDT
Please can you provide a /var/log/dnf.log and output from journalctrl from the time of system-upgrade download, and reboot/upgrade

Thanks a lot.
Comment 2 Miro Hrončok 2017-10-05 10:57 EDT
Created attachment 1334891 [details]
dnf.log
Comment 3 Miro Hrončok 2017-10-05 11:03 EDT
Created attachment 1334893 [details]
journalctl log
Comment 4 Jaroslav Mracek 2017-10-06 02:50:52 EDT
Thanks, please could you try the following?

``# dnf check`` #Just to be sure that there are not duplicates on your system

``# dnf clean all``

``# dnf system-upgrade clean``

``# dnf reinstall python3-dnf-0:2.7.2-1.fc26.noarch python3-dnf-plugin-system-upgrade-0:2.0.3-1.fc26.noarch``

``# dnf system-upgrade clean`` 

``# dnf system-upgrade download`` #like you did previously

``# dnf system-upgrade reboot``


Hope that something was incorrect in cache...

Output from that experiment could be handy
Comment 5 Miro Hrončok 2017-10-06 05:40:11 EDT
(In reply to Jaroslav Mracek from comment #4)
> Thanks, please could you try the following?
> 
> ``# dnf check`` #Just to be sure that there are not duplicates on your system

That one is OK - no output, exit code 0.

Will continue with the rest later. Thanks for suggestions.
Comment 6 LiZhenbo 2017-10-06 17:25 EDT
Created attachment 1335539 [details]
dnf.log

I have the same problem when upgrading F26->F27
My procedure:
    sudo dnf system-upgrade --releasever=27 download
    sudo dnf system-upgrade reboot

My XPS just rebooted twice, and it went back to F26

I'll try Comment 4

Besides, is this a Common F27 bug?
https://fedoraproject.org/wiki/Common_F27_bugs
Comment 7 LiZhenbo 2017-10-06 17:52 EDT
Created attachment 1335558 [details]
Comment4_dnf.log

Comment 4 didn't work for me
My root history:
   
   86  dnf check
   87  dnf clean all
   88  dnf system-upgrade clean
   89  dnf reinstall python3-dnf-0:2.7.2-1.fc26.noarch python3-dnf-plugin-system-upgrade-0:2.0.3-1.fc26.noarch
   90  dnf system-upgrade clean
   91  dnf system-upgrade download --releaserver=27
   92  dnf system-upgrade download --releasever=27
   93  dnf system-upgrade reboot

After rebootng twice, I went back to F26

This is my /var/log/dnf.log
Comment 8 LiZhenbo 2017-10-06 17:54 EDT
Created attachment 1335559 [details]
Comment4_journalctl

journalctl --since=2017-10-06

Sorry, I'm not sure which boot is the 'exact' one.
Comment 9 Jaroslav Mracek 2017-10-09 03:38:10 EDT
I see that in attachment in Comment 8 line *** Error in `/usr/libexec/system-python': free(): invalid pointer: 0x00007fca35ec8e20 ***
therefore the issue here (Comment 6, 7, and 8) is duplicate of Bug 1498207.
Comment 10 hugotrip 2017-10-09 07:05 EDT
Created attachment 1336350 [details]
log of the system-upgrade in dnf

It seems I'm encountering the same bug,
Comment 11 hugotrip 2017-10-09 07:13 EDT
Created attachment 1336352 [details]
Log of the reboot (journalctl -b ...) part of the system-upgrade

but it doesn't seem to involve a python error, but an attempt from dnf to sync cache for fedora (line 1252 of this log and lines 21739-end of file for the dnf log).
Plus, the error is different from bug 1492036 (workaround from here -dnf makecache- doesn't work, and update to dnf-plugin-system-upgrade-2.0.3-1.fc26 didn't work either)
Comment 12 Jaroslav Mracek 2017-10-10 12:15:22 EDT
I don't see hugotrip@free.fr why it doesn't have a cache for fedora repo. I can suggest only to add makecache in example and upgrade to latest version of dnf packages. 

Please try latest upgrades
dnf-2.7.3-1.fc26
dnf-plugins-core-2.1.5-1.fc26
dnf-plugins-extras-2.0.3-1.fc26
libdnf-0.11.0-1.fc26 (downloadable from https://koji.fedoraproject.org/koji/buildinfo?buildID=982583)



``# dnf check`` #Just to be sure that there are not duplicates on your system

``# dnf clean all``

``# dnf makecache``

``# dnf system-upgrade clean``

``# dnf reinstall python3-dnf-0:2.7.2-1.fc26.noarch python3-dnf-plugin-system-upgrade-0:2.0.3-1.fc26.noarch``

``# dnf system-upgrade clean`` 

``# dnf system-upgrade download`` #like you did previously

``# dnf system-upgrade reboot``
Comment 13 Adam Goode 2017-10-10 22:22:07 EDT

*** This bug has been marked as a duplicate of bug 1498207 ***

Note You need to log in before you can comment on or make changes to this bug.