Bug 14989 - SMTP connect to localhost failed
Summary: SMTP connect to localhost failed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fetchmail   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-01 16:15 UTC by dpawluk
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 18:58:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dpawluk 2000-08-01 16:15:45 UTC
fetchmail: POP3> LIST
fetchmail: POP3< +OK 4 messages
fetchmail: POP3< 1 3463
fetchmail: POP3< 2 2589
fetchmail: POP3< 3 17792
fetchmail: POP3< 4 2427
fetchmail: POP3< .
fetchmail: POP3> TOP 1 99999999
fetchmail: POP3< +OK 3463 octets
reading message 1 of 4 (3463 octets)
fetchmail: SMTP connect to localhost failed
fetchmail: POP3> QUIT
fetchmail: POP3< 
fetchmail: SMTP transaction error while fetching from mail
fetchmail: Query status=10 (SMTP)
fetchmail: normal termination, status 10
Done.

it looks like sendmail is rejecting the emails.
localhost is allowed in /etc/mail/access

this is my .fetchmailrc

# Configuration created Thu Jul 27 22:23:20 2000 by fetchmailconf
set postmaster "postmaster"
set bouncemail
set properties ""
set daemon 60
poll mail with proto POP3
    user dpawluk there with password ******** is root here warnings 3600
    antispam 571 550 501 554
    user dwp there with password ******** is root here warnings 3600
    antispam 571 550 501 554

Comment 1 Jeremy Katz 2000-08-01 18:58:52 UTC
sendmail in pinstripe is configured to run in queue-only mode as opposed to
daemon mode.  To change back to the previous behavior, you need to edit
/etc/sysconfig/sendmail

Comment 2 Nalin Dahyabhai 2000-08-01 19:28:06 UTC
Sendmail listening is now disabled by default as a security measure.  Invoke
fetchmail with the "--mda=/usr/bin/procmail" command-line option or add "mda
/usr/bin/procmail" to the appropriate "poll" section of your .fetchmailrc file,
and things should work properly again.


Note You need to log in before you can comment on or make changes to this bug.