Bug 1498922 - ppc64le Cloud Base image got cloud-init timeouts at restart
Summary: ppc64le Cloud Base image got cloud-init timeouts at restart
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cloud-init
Version: 27
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Garrett Holmstrom
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-10-05 14:44 UTC by Menanteau Guy
Modified: 2017-11-03 12:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-03 12:48:56 UTC


Attachments (Terms of Use)
journalctl result (84.29 KB, text/x-vhdl)
2017-10-05 14:44 UTC, Menanteau Guy
no flags Details

Description Menanteau Guy 2017-10-05 14:44:00 UTC
I am testing Fedora-Cloud-Base-27-20171004.n.0.ppc64le.qcow2 in a local environment. When I run the image the first time using a cdrom with user-data and meta-data, the VM start smoothly and I get the prompt quickly.
But when I run restart this image a second time without the cdrom, then I get a lot of timeouts because cloud-init try to reach a metadata local address that does not exist. This make the prompt very long to have.

On the first VM start I used:
/usr/bin/qemu-system-ppc64 -name cloud-host -enable-kvm -M pseries -smp 4 -m 4G -nographic -nodefaults -monitor stdio -serial pty -device virtio-net-pci,netdev=net10133,mac=c0:ff:ee:00:00:93 -netdev bridge,br=br0,id=net10133 -hda cloud.qcow2 -cdrom cloud01-cidata.iso -S

where cloud01-cidata.iso was created by "genisoimage" using my meta-data file and my user-data file. This work fine.

On  the second start, I removed the cdrom as I think all info are already in the image now.
/usr/bin/qemu-system-ppc64 -name cloud-host -enable-kvm -M pseries -smp 4 -m 4G -nographic -nodefaults -monitor stdio -serial pty -device virtio-net-pci,netdev=net10133,mac=c0:ff:ee:00:00:93 -netdev bridge,br=br0,id=net10133 -hda cloud.qcow2 -S

But then I got several timeouts messages like:
Oct 05 12:55:22 atomic01.toulouse-stg.fr.ibm.com cloud-init[738]: 2017-10-05 12:55:22,182 - url_helper.py[WARNING]: Calling 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [50/120s]: request error [HTTPConnectionPool(host='169.254.169.254', port=80): Max retries exceeded with url: /2009-04-04/meta-data/instance-id (Caused by ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x7fffb88a2a20>, 'Connection to 169.254.169.254 timed out. (connect timeout=50.0)'))]

This leads to several minutes init before getting the prompt.

Comment 1 Menanteau Guy 2017-10-05 14:44:31 UTC
Created attachment 1334883 [details]
journalctl result

Comment 2 Menanteau Guy 2017-11-03 12:48:56 UTC
Sorry for the noise, I forgot to create the file /etc/cloud/cloud-init.disabled  to not run cloud-init on my second reboot without the cdrom. I don't have timeout  problems anymore.


Note You need to log in before you can comment on or make changes to this bug.