Bug 149900 - cdrecord burns CDs which cannot be read back
cdrecord burns CDs which cannot be read back
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 12:52 EST by Davide Bolcioni
Modified: 2008-11-26 16:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 16:00:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2005-02-28 12:52:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
When attempting to burn a CD, a warning is printed

  cdrecord: WARNING: Drive returns wrong startsec (0) using -150

but apparently the CD gets written. After ejecting it and mounting it successfully, attempting to verify it using

  tar cf /dev/zero /media/cdrom

result in a slew of I/O errors like

...
tar: /media/cdrecorder/Varie/refman.pdf: Read error at byte 0, reading 6656 bytes: Input/output error
tar: /media/cdrecorder/Varie/servlet-2_3-fcs-spec.pdf: Read error at byte 0, reading 2048 bytes: Input/output error
...

Version-Release number of selected component (if applicable):
cdrecord-2.01.1-5

How reproducible:
Always

Steps to Reproduce:
1. Create an ISO image using "mkisofs -R -o cd.iso cd-dir" and get the tsize.
2. Attempt to burn it using

  cdrecord -dao dev=ATA:1,1,0 driveropts=burnfree tsize=183138 cd.iso

or

  cdrecord dev=ATA:1,1,0 driveropts=burnfree cd.iso

3. Eject the CD, put it back in and mount it.

4. Attempt the following command

   tar cf /dev/zero /media/cdrom
  

Actual Results:  A slew of I/O errors on the console.

Expected Results:  No I/O Error.

Additional info:

Scanning the ATA bus reports:

scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'DVD-16X ' 'OEM316B         ' '1.00' Removable CD-ROM
        1,1,0   101) 'BTC     ' 'BCE1610IM       ' 'A.20' Removable CD-ROM
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
Comment 1 Harald Hoyer 2005-03-01 06:08:03 EST
Could you try to burn with the newest update kernel and:
# cdrecord -dao dev=/dev/cdwriter driveropts=burnfree cd.iso
Comment 2 Davide Bolcioni 2005-03-01 10:20:41 EST
Tried with the above command and kernel-2.6.10-1.766_FC3, the very same CD
burned and verified OK. May I suggest that the output of -scanbus might include
the above, since it is apparently critical and most documentation for cdrecord
points to the output of -scanbus as the definitive answer ?
Comment 3 Harald Hoyer 2005-03-01 11:58:29 EST
good point! I will do that and release an update
Comment 4 Matthew Miller 2006-07-10 16:41:46 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 5 Davide Bolcioni 2007-01-24 11:36:48 EST
Just tried it with Fedora Core 6: the scanbus option does not warn about the 
dev=/dev/something option. Furthermore, dev=help does not list it either.
Comment 6 Davide Bolcioni 2008-01-13 16:06:01 EST
Just tried it with Fedora 7: the scanbus option does not warn about the 
dev=/dev/something option. Furthermore, dev=help does not list it either and 
actually says that open through Unix device is not supported.
Comment 7 Davide Bolcioni 2008-02-28 16:15:26 EST
Just tried it with Fedora 8: the scanbus option does not warn about the 
dev=/dev/something option. Furthermore, dev=help does not list it either.

What is the bugzilla component corresponding to wodim-1.1.6-6.fc8 ?
Comment 8 Bug Zapper 2008-11-26 01:49:07 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Davide Bolcioni 2008-11-26 16:00:15 EST
This is probably no longer relevant.

Note You need to log in before you can comment on or make changes to this bug.