Bug 1499025 - samba-3.6.23-45.el6_9:0.x86_64 breaks directory listing
Summary: samba-3.6.23-45.el6_9:0.x86_64 breaks directory listing
Keywords:
Status: CLOSED DUPLICATE of bug 1495148
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba
Version: 6.9
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-05 20:47 UTC by aheverle
Modified: 2017-11-01 13:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-19 14:08:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description aheverle 2017-10-05 20:47:23 UTC
Description of problem:

Since installing samba-3.6.23-45.el6_9:0.x86_64, users can no longuer see files inside shared directories. The listing works at the topmost part of the share, but as soon as you dig down one level of directory, the files inside aren't visible anymore.

Please see these 2 very short links. This is 2 people reporting the same problem:
https://www.centos.org/forums/viewtopic.php?t=64334
http://samba.2283325.n4.nabble.com/problems-with-samba-shares-td4724556.html

The workaround for the moment seems to be yum downgrade to the last known working version, which is 3.6.23-44.el6_9. For it to work for myself, i've had to  go to version 3.6.23-43.el6_9 because i do not have version 3.6.23-44.el6_9 in my cloned channel on my satellite server.

So the cmd below effectively restored the functionality for me:
# yum downgrade samba-winbind-3.6.23-43.el6_9.x86_64 samba-winbind-clients-3.6.23-43.el6_9.x86_64 samba-3.6.23-43.el6_9.x86_64 samba-common-3.6.23
-43.el6_9.x86_64 samba-client-3.6.23-43.el6_9.x86_64

Version-Release number of selected component (if applicable):
samba-3.6.23-45.el6_9

How reproducible:
Everytime

Comment 3 Andreas Schneider 2017-10-19 14:08:34 UTC

*** This bug has been marked as a duplicate of bug 1495148 ***


Note You need to log in before you can comment on or make changes to this bug.