Bug 1499052 - usbguard-daemon fails with kernel 4.13
Summary: usbguard-daemon fails with kernel 4.13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: usbguard
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Kopeček
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-05 23:32 UTC by Chris Irwin
Modified: 2017-11-11 02:54 UTC (History)
4 users (show)

Fixed In Version: usbguard-0.7.0-7.fc27 usbguard-0.7.0-3.fc26 usbguard-0.7.0-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-06 23:33:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Chris Irwin 2017-10-05 23:32:55 UTC
Description of problem:

usbguard-0.7.0-6.fc27 fails to run on Fedora 27, affecting a freshly-upgraded laptop.

Version-Release number of selected component (if applicable):

usbguard-0.7.0-6.fc27

How reproducible:

Every time, using f27 kernel 4.13.4-300.fc27.x86_64

Steps to Reproduce:
1. Boot Fedora 27
2. systemctl start usbguard
3. (alternatively, to see the error) sudo usbguard-daemon -d -k

Actual results:

usbguard-daemon fails to run

Expected results:

usbguard-daemon runs

Additional info:

Documented in upstream bug #204: https://github.com/dkopecek/usbguard/issues/204

Looks to be fixed in upstream commit c305bcec: https://github.com/dkopecek/usbguard/commit/c305bcec6f4c7fc6f16d84d300dc8f4331ca5b6c

Which appears to be included and working in the usbguard-testing COPR: https://copr.fedorainfracloud.org/coprs/mildew/usbguard-testing

Comment 1 Wolfgang Pfeiffer 2017-10-12 17:37:24 UTC
Can confirm the bug for an install a few hours ago of linux 4.13.5-200.fc26.x86_64. 
Linux 4.12.14-300 seems to work fine with usbguard 0.7.0-2.fc26

Any chance to get the fixed package loaded at least into the regular testing repo of Fedora 26?

TIA.

Errors, exerpt, via journalctl, grepped for 'usbguard|4.13.5':

===================================

Oct 11 22:54:06 [deleted hostname] systemd[1]: Started USBGuard daemon.
Oct 11 22:54:06 [deleted hostname] audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? ad
dr=? terminal=? res=success'
Oct 11 22:54:06 [deleted hostname] usbguard-daemon[2292]: [1507755246.624] (W) udev backend is OBSOLETE. Falling back to new default: uevent
Oct 11 22:54:28 [deleted hostname] usbguard-daemon[2292]: [1507755268.626] (E) ERROR: UEventDeviceManager: present devices: enumeration timeout
Oct 11 22:54:28 [deleted hostname] systemd[1]: usbguard.service: Main process exited, code=exited, status=1/FAILURE
Oct 11 22:54:28 [deleted hostname] systemd[1]: usbguard.service: Unit entered failed state.
Oct 11 22:54:28 [deleted hostname] audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? add
r=? terminal=? res=failed'
Oct 11 22:54:28 [deleted hostname] systemd[1]: usbguard.service: Failed with result 'exit-code'.
Oct 11 22:54:28 [deleted hostname] systemd[1]: usbguard.service: Service hold-off time over, scheduling restart.
Oct 11 22:54:28 [deleted hostname] systemd[1]: Stopped USBGuard daemon.
Oct 11 22:54:28 [deleted hostname] audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? ad
dr=? terminal=? res=success'
Oct 11 22:54:28 [deleted hostname] audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? add
r=? terminal=? res=success'
Oct 11 22:54:28 [deleted hostname] systemd[1]: Started USBGuard daemon.
Oct 11 22:54:28 [deleted hostname] audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? ad
dr=? terminal=? res=success'
Oct 11 22:54:28 [deleted hostname] usbguard-daemon[2352]: [1507755268.867] (W) udev backend is OBSOLETE. Falling back to new default: uevent
Oct 11 22:54:30 [deleted hostname] /usr/libexec/gdm-x-session[2349]: Current Operating System: Linux [deleted hostname] 4.13.5-200.fc26.x86_64 #1 SMP Thu Oct 5 16:53:13 UTC 2017 x86_64
Oct 11 22:54:30 [deleted hostname] /usr/libexec/gdm-x-session[2349]: Kernel command line: BOOT_IMAGE=/vmlinuz-4.13.5-200.fc26.x86_64 root=UUID=00388e5d-df35-4825-bd0c-846aaca2bac5 ro rd.luks.uuid=luks-6ec3f3ab-c5d1-4e4a-b263-c375daf64c11 rhgb quiet LANG=en_US.UTF-8
Oct 11 22:54:50 [deleted hostname] usbguard-daemon[2352]: [1507755290.870] (E) ERROR: UEventDeviceManager: present devices: enumeration timeout
Oct 11 22:54:50 [deleted hostname] systemd[1]: usbguard.service: Main process exited, code=exited, status=1/FAILURE
Oct 11 22:54:50 [deleted hostname] systemd[1]: usbguard.service: Unit entered failed state.
Oct 11 22:54:50 [deleted hostname] audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=usbguard comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 11 22:54:50 [deleted hostname] systemd[1]: usbguard.service: Failed with result 'exit-code'.
Oct 11 22:54:51 [deleted hostname] systemd[1]: usbguard.service: Service hold-off time over, scheduling restart.
Oct 11 22:54:51 [deleted hostname] systemd[1]: Stopped USBGuard daemon.


===================================

Thanks again!

Best Regards
Wolfgang

Comment 2 Harish Pillay 2017-10-14 04:41:44 UTC
Facing the same issue on F26:
% uname -a
Linux gillman.sin.redhat.com 4.13.5-200.fc26.x86_64 #1 SMP Thu Oct 5 16:53:13 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

% systemctl status bluetooth.service -l
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2017-10-14 12:28:34 +08; 34s ago
     Docs: man:bluetoothd(8)
 Main PID: 24484 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─24484 /usr/libexec/bluetooth/bluetoothd

Oct 14 12:28:34 gillman.sin.redhat.com systemd[1]: Starting Bluetooth service...
Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Bluetooth daemon 5.46
Oct 14 12:28:34 gillman.sin.redhat.com systemd[1]: Started Bluetooth service.
Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Starting SDP server
Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Bluetooth management interface 1.14 initialized

but usbguard-applet-qt says:
Connection failed: IPC connect: service=usbguard: Connection refused

Comment 3 Harish Pillay 2017-10-14 04:44:56 UTC
(In reply to Harish Pillay from comment #2)
> Facing the same issue on F26:
> % uname -a
> Linux gillman.sin.redhat.com 4.13.5-200.fc26.x86_64 #1 SMP Thu Oct 5
> 16:53:13 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
> 
> % systemctl status bluetooth.service -l
> ● bluetooth.service - Bluetooth service
>    Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled;
> vendor preset: enabled)
>    Active: active (running) since Sat 2017-10-14 12:28:34 +08; 34s ago
>      Docs: man:bluetoothd(8)
>  Main PID: 24484 (bluetoothd)
>    Status: "Running"
>    CGroup: /system.slice/bluetooth.service
>            └─24484 /usr/libexec/bluetooth/bluetoothd
> 
> Oct 14 12:28:34 gillman.sin.redhat.com systemd[1]: Starting Bluetooth
> service...
> Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Bluetooth daemon
> 5.46
> Oct 14 12:28:34 gillman.sin.redhat.com systemd[1]: Started Bluetooth service.
> Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Starting SDP server
> Oct 14 12:28:34 gillman.sin.redhat.com bluetoothd[24484]: Bluetooth
> management interface 1.14 initialized
> 
> but usbguard-applet-qt says:
> Connection failed: IPC connect: service=usbguard: Connection refused

Wrong service info above. The right one is below:

# systemctl status usbguard.service -l
● usbguard.service - USBGuard daemon
   Loaded: loaded (/usr/lib/systemd/system/usbguard.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2017-10-14 12:43:59 +08; 2s ago
     Docs: man:usbguard-daemon(8)
 Main PID: 25571 (usbguard-daemon)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/usbguard.service
           └─25571 /usr/sbin/usbguard-daemon -k -c /etc/usbguard/usbguard-daemon.conf

Oct 14 12:43:59 gillman.sin.redhat.com systemd[1]: Started USBGuard daemon.
Oct 14 12:43:59 gillman.sin.redhat.com usbguard-daemon[25571]: [1507956239.924] (W) udev backend is OBSOLETE. Falling back to new default: uevent

Harish

Comment 4 Daniel Kopeček 2017-10-16 06:16:46 UTC
Hi all and thanks for the report! I'll submit an update ASAP.

Comment 6 Fedora Update System 2017-10-16 08:41:54 UTC
usbguard-0.7.0-7.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-025f2ca131

Comment 7 Fedora Update System 2017-10-16 08:42:00 UTC
usbguard-0.7.0-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cb74d0312b

Comment 8 Fedora Update System 2017-10-16 18:22:45 UTC
usbguard-0.7.0-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cb74d0312b

Comment 9 Fedora Update System 2017-10-17 02:24:18 UTC
usbguard-0.7.0-7.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-025f2ca131

Comment 10 Fedora Update System 2017-10-25 14:00:34 UTC
usbguard-0.7.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bc86eddb1e

Comment 11 Fedora Update System 2017-10-25 23:11:13 UTC
usbguard-0.7.0-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-10-26 01:12:01 UTC
usbguard-0.7.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bc86eddb1e

Comment 13 Fedora Update System 2017-11-06 23:33:11 UTC
usbguard-0.7.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-11-11 02:54:32 UTC
usbguard-0.7.0-7.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.