Bug 149908 - dhclient doesn't set gateway properly.
dhclient doesn't set gateway properly.
Status: CLOSED DUPLICATE of bug 149780
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 14:11 EST by Jonathan Ryshpan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Ryshpan 2005-02-28 14:11:46 EST
Description of problem:
New dhclient doesn't set gateway properly.

Version-Release number of selected component (if applicable):
dhclient-3.0.1-40_FC3.x86_64.rpm

How reproducible:
If the connection to the internet is eth0, an ifcfg-eth0 script with a
bad value for "GATEWAY=" will cause the value of gateway to be put
into the routing table.

Steps to Reproduce:
1. In ifcfg-eth0 enter
        ...
        BOOTPROTO=dhcp
        ...
        GATEWAY=192.168.10.1
        ...
2. invoke
        ifup eth0
  
Actual results:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref   
Use Iface
169.254.0.0     *               255.255.0.0     U     0      0       
0 eth0
192.168.0.0     *               255.255.0.0     U     0      0       
0 eth0
default         192.168.10.1    0.0.0.0         UG    0      0       
0 eth0

Expected results:
route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref   
Use Iface
169.254.0.0     *               255.255.0.0     U     0      0       
0 eth0
192.168.0.0     *               255.255.0.0     U     0      0       
0 eth0
default         192.168.0.1     0.0.0.0         UG    0      0       
0 eth0


Additional info:
This problem started when I "upgraded" from 
    dhclient-3.0.1-30_FC3.x86_64.rpm
to
    dhclient-3.0.1-40_FC3.x86_64.rpm
Comment 1 Jason Vas Dias 2005-02-28 14:53:13 EST
You've set GATEWAY to :
   GATEWAY=192.168.10.1
in ifcfg-eth0.
With dhcp-3.0.1-40_FC3, the dhclient-script now correctly honors the
GATEWAY and GATEWAYDEV settings. 

If the ip-address and subnet-mask received from DHCP are on the same
subnet as the "$GATEWAY" setting, "$GATEWAY" becomes the gateway of
the default route, which in your case is 192.168.10.1 .

If you don't want dhclient-script to set the gateway to this value,
remove or comment out the GATEWAY setting in ifcfg-eth0 .



*** This bug has been marked as a duplicate of 149780 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.