Bug 1499126 - Not possible to change ValidNumOfMonitors as wrong data type set
Summary: Not possible to change ValidNumOfMonitors as wrong data type set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Tomas Jelinek
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-06 07:08 UTC by Jaroslav Spanko
Modified: 2021-05-01 16:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the current release, ValidNumOfMonitors can be configured with engine-config.
Clone Of:
Environment:
Last Closed: 2018-05-15 17:45:15 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:46:19 UTC
oVirt gerrit 82772 0 master MERGED core: fix ValidNumOfMonitors 2017-11-24 14:11:40 UTC

Description Jaroslav Spanko 2017-10-06 07:08:39 UTC
Description of problem:
It is not possible to set string value for ValidNumOfMonitors

Default value
engine-config -g ValidNumOfMonitors
ValidNumOfMonitors: 1,2,4 version: general

Custom value
engine-config -s ValidNumOfMonitors=1,2
Cannot set value 1,2 to key ValidNumOfMonitors. 

As from the /etc/ovirt-engine/engine-config/engine-config.properties
ValidNumOfMonitors.description="Valid Numbers of Monitors"
ValidNumOfMonitors.type=Integer

Once is set to String the engine-config works

Version-Release number of selected component (if applicable):
4.1.9

How reproducible:
100%

Steps to Reproduce:
1. Change the default value of ValidNumOfMonitors
2. Cannot set value


Actual results:
Cannot set value

Expected results:
As the default value is 1,2,4 possibility to change it to similar

Comment 2 Israel Pinto 2017-12-07 14:10:38 UTC
Verify with: Software Version:4.2.0-0.6.el7

Cases:
1.
Checked: engine-config -s ValidNumOfMonitors="1,2"
Results: engine-config -g ValidNumOfMonitors
ValidNumOfMonitors: 1,2 version: general
2.
engine-config -s ValidNumOfMonitors="1,2,4"
engine-config -g ValidNumOfMonitors
ValidNumOfMonitors: 1,2,4 version: general


PASS

Comment 6 errata-xmlrpc 2018-05-15 17:45:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 7 Franta Kust 2019-05-16 13:07:04 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.