Bug 149914 - evince - "reload" broken beyond recognition
evince - "reload" broken beyond recognition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 14:49 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 14:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a log from an attempt to "reload" something in evince (3.17 KB, text/plain)
2005-04-22 17:13 EDT, Michal Jaegermann
no flags Details
another backtrace from evince; this time 0.2.1-1 (2.81 KB, text/plain)
2005-04-27 21:28 EDT, Michal Jaegermann
no flags Details
yet another traceback, this one for v. 0.3.1 (4.20 KB, text/plain)
2005-07-02 02:35 EDT, michael kuhlen
no flags Details

  None (edit)
Description Michal Jaegermann 2005-02-28 14:49:38 EST
Description of problem:

With a Postscript file loaded into evince hitting "Ctrl-R"
or picking "Reload" from a menu most likely will bring
to a screen "crash alert", although this is somewhat unpredictable,
and various messages will show up in a terminal window if you
are running from a terminal.  What will show up is not exactly
deterministic but something like that seems to be the most
popular:

(evince:4560): GLib-GObject-WARNING **: invalid uninstantiatable type
`(null)' in cast to `EvDocument'

(evince:4560): GLib-GObject-WARNING **: invalid uninstantiatable type
`(null)' in cast to `GObject'

(evince:4560): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `(null)'

(evince:4560): GLib-GObject-CRITICAL **: g_signal_emit_valist:
assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

I have seen also messages like:

GLib-GObject-WARNING **: invalid uninstantiatable type `GEnum' in cast
to `EvDocument'

and like the first three quoted but with "type `(null)'" replaced
by "type `<invalid>'".  It may happen also that nothing is printed
but basically evince is dead after such experiment regardless
of what was displayed.

This happens equally well on x86 and x86_64 installations.

Version-Release number of selected component (if applicable):
evince-0.1.5-1

How reproducible:
100%
Comment 1 Michal Jaegermann 2005-02-28 15:07:18 EST
I guess that the following can be added to the list above:

(evince:5962): Gdk-CRITICAL **: gdk_region_destroy: assertion `r !=
NULL' failed
Comment 2 Marco Pesenti Gritti 2005-02-28 16:57:28 EST
Fixed upstream, will be in the next release.
Comment 3 Michal Jaegermann 2005-04-22 17:13:22 EDT
Created attachment 113577 [details]
a log from an attempt to "reload" something in evince

This bug got status CLOSED RAWHIDE but with evince-0.2.0-1 with a build date
"Wed 06 Apr 2005 04:07:46 AM MDT" the situation is actually even worse than
it used to be.	Either hitting Ctrl-R or picking up "Reload" from a menu
scrambles display and effectively completely crashes evince.  This attachment
includes a record from such attempt.
Comment 4 Jeremy Katz 2005-04-27 21:00:46 EDT
Is 0.2.1 better?
Comment 5 Michal Jaegermann 2005-04-27 21:28:41 EDT
Created attachment 113754 [details]
another backtrace from evince; this time 0.2.1-1

> Is 0.2.1 better?
I would not say so.  I see either alerts "application quit unexpectedly" and/or

backtraces of that sort as attached.  It is similar but not really the same
as the one from the previous attachment so here is another sample from 0.2.1.
Comment 6 michael kuhlen 2005-07-02 02:35:49 EDT
Created attachment 116274 [details]
yet another traceback, this one for v. 0.3.1
Comment 7 michael kuhlen 2005-07-02 02:39:40 EDT
Comment on attachment 116274 [details]
yet another traceback, this one for v. 0.3.1

This problem persists in Fedora Core 4, which ships with evince 0.3.1.

I have attached yet another backtrace.

The bug status still is NEEDINFO, what further information would be helpful?
Comment 8 michael kuhlen 2005-07-02 20:59:40 EDT
I compiled evince 0.3.2, and this bug appears to have been fixed.
Comment 9 Marius Andreiana 2005-08-19 15:40:47 EDT
I get only
** (evince:14727): CRITICAL **: ps_document_next_page: assertion `gs->busy !=
TRUE' failed

on start and each reload, and no problems in GUI.
Using evince 0.3.1 on FC4 up to date.

Would you please attach your problematic .ps file or post a link to it?
Comment 10 Michal Jaegermann 2005-08-27 17:36:29 EDT
With evince-0.4.0-1 I can hit Ctrl-R, or pick up "Reload" from a menu, many times
without causing crashes.  OTOH each such operation results in:

(evince:28032): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT
(object)' failed

for a change.
Comment 11 Kristian Høgsberg 2006-09-22 14:31:33 EDT
I can't reproduce this.  I tried with evince-0.5.5 and a bunch of different ps
files.  If this is still a problem, please reopen, but do attach the problematic
ps file in that case.

thanks,
Kristian
Comment 12 Michal Jaegermann 2006-09-22 15:27:49 EDT
> I can't reproduce this.

Well, a date on the original report was "2005-02-28". :-)
Also I did not bother with evince for quite a while.

Note You need to log in before you can comment on or make changes to this bug.