Bug 149917 - Does RedHat Enterprise Linux-v4 does not boot with RAID Autodetect/AHCI controller
Does RedHat Enterprise Linux-v4 does not boot with RAID Autodetect/AHCI contr...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Milburn
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 15:20 EST by Redhat Questions
Modified: 2009-07-27 17:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 17:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Redhat Questions 2005-02-28 15:20:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I was trying to boot Redhat Linux ES v4(2.6.9-5.0.3.ELsmp) with RAID 
Autodetect/AHCI controller SATA operation. The disk is properly 
fragmented to load both Linux and Windows. The system does not boot 
with Linux, and is stuck with following information:

Kernel panic - not syncing:Attempted to kill init! 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use a computer with SATA drive
2.Select  as SATA operation. To do this do the following:
i) When system is coming  up press F2, select Drivers, select SATA 
operation and select RAID Autodetect/AHCI controller.
3.Try to boot the system with Linux
    

Actual Results:  System never boots.

Expected Results:  System should boot.

Additional info:
Comment 1 Redhat Questions 2005-02-28 15:55:20 EST
Please note that I am using a Dell PC with Intel(R) 82801FR SATA AHCI 
controller. Does RedHat have driver for 2.6 kernel? 
Comment 2 Suzanne Hillman 2005-03-01 12:49:18 EST
This is during, or post, install?

I ask because Anaconda is for during installation...
Comment 3 Redhat Questions 2005-03-02 13:24:10 EST
It is during installation.
Comment 4 Chris Lumens 2005-03-11 13:42:14 EST
Yes, this controller should be supported under RHEL4.  How are you trying to
install - from CD, over NFS, etc.?
Comment 5 Redhat Questions 2005-03-21 14:42:02 EST
I am trying to install it from CD.
Comment 6 Alexander Dalloz 2005-03-25 10:39:22 EST
I have the same experience with an Intel SE7221BK1-E board. Data from lspci:

00:00.0 Host bridge: Intel Corp. E7220/E7221 Memory Controller Hub (rev 05)
00:1f.2 IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA Controller
(rev 03)

In the BIOS I can set IDE / RAID /AHCI. As the RAID function is pure BIOS
supported software RAID and AHCI not ready with Linux (last part correct?) I am
using the IDE setting. Booting without any kernel parameter the system only gets
to the kernel uncompressing message and a final line:

kernel direct mapping tables up to 10100000000@8000-b000

Booting with "noapci" helps, install succeeds and all 3 SATA drives are properly
found.
Comment 7 David Milburn 2009-07-27 17:34:46 EDT
This should not be a problem with RHEL4 U8, please re-open if this is reproducible
with 2.6.9-89 kernel.

Note You need to log in before you can comment on or make changes to this bug.