Bug 1499170 - ibus not working in fresh Workstation Live install with user account setup in gnome-initial-setup
Summary: ibus not working in fresh Workstation Live install with user account setup in...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On: 1502827
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-06 09:54 UTC by Jens Petersen
Modified: 2017-11-14 01:55 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-31 15:38:45 UTC


Attachments (Terms of Use)

Description Jens Petersen 2017-10-06 09:54:32 UTC
Description of problem:
After installing latest Fedora 27 Workstation Live

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-27-20171005.n.0.iso
Fedora-Workstation-Live-x86_64-27_Beta-1.5.iso

How reproducible:
100%

Steps to Reproduce:
1. install Workstation Live in Japanese with setting up user in anaconda
2. setup Japanese user in gnome-initial-setup with kkc IME
3. Login to desktop
4. Start gedit
5. turn on kkc and try to input Japanese

Actual results:
5. Just direct ascii input - can't input or pre-edit any Japanese characters

Expected results:
5. Japanese input to work normally

Additional info:
Not sure yet if setting up user in Anaconda makes any difference.

Workaround seems to be to add another IME using gnome-control-center.

Comment 1 Mike FABIAN 2017-10-06 11:17:56 UTC
I tried both Fedora-Workstation-Live-x86_64-27_Beta-1.5.iso
and Fedora-Workstation-netinst-x86_64-27_Beta-1.5.iso doing
the Install in Japanese, accepting all the defaults
(except that I added a user in Anaconda) and it worked for me
in both cases.

Comment 2 Mike FABIAN 2017-10-06 14:45:32 UTC
Now I tried again, Fedora-Workstation-Live-x86_64-27_Beta-1.5.iso, 
install in Japanese, added "English (US)" keyboard and *removed*
the Japanese keyboard layout. Otherwise excepted all defaults
except adding a user in Anaconda.

In gnome-initial-setup I did chose kkc. Japanese input then worked
immediately for me.

Comment 3 Mike FABIAN 2017-10-06 15:47:24 UTC
I always tried  with setting up the user in anaconda in comment#1 and
comment#2, so maybe that makes a differencė

Comment 4 Mike FABIAN 2017-10-06 16:42:20 UTC
(In reply to Mike FABIAN from comment #3)
> I always tried  with setting up the user in anaconda in comment#1 and
> comment#2, so maybe that makes a differencė

Now I tried without setting up a user in anaconda, and it *does*
make a difference.

Japanese input did not work immediately for me.

So without creating a user in anaconda, I can reproduce the problem
in comment#1.

Comment 5 Jens Petersen 2017-10-07 04:11:21 UTC
Thanks, Mike!

Moving this to gnome-initial-setup then since it looks like a regression.

Comment 6 Jens Petersen 2017-10-25 06:42:08 UTC
This is probably also a duplicate of bug 1502827

Comment 7 Adam Williamson 2017-10-25 16:17:48 UTC
I don't see how? That bug is about g-i-s not showing up at all. This bug is about it apparently not configuring input methods correctly.

Nominating for a Final FE, because we can't fix this fully with an update - it'd still be broken for live installs, for e.g. Also marking CommonBugs in case we don't fix it, so we can document it.

Comment 8 Rui Matos 2017-10-26 14:57:44 UTC
This seems to be a selinux problem. After setting it to permissive I can create a user in gnome-initial-setup and set it to use IBus input sources successfully. I believe these are the relevant AVCs:

Oct 26 16:50:36 localhost.localdomain audit[2899]: AVC avc:  denied  { map } for  pid=2899 comm="systemd-localed" path="/usr/share/X11/xkb/rules/ev
dev" dev="vda1" ino=394858 scontext=system_u:system_r:systemd_localed_t:s0 tcontext=system_u:object_r:usr_t:s0 tclass=file permissive=1

Oct 26 16:50:36 localhost.localdomain audit[2705]: AVC avc:  denied  { map } for  pid=2705 comm="gsd-keyboard" path="/run/gnome-initial-setup/.conf
ig/dconf/user" dev="tmpfs" ino=46979 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:xdm_var_run_t:s0 tclass=file pe
rmissive=1

Comment 9 Adam Williamson 2017-10-26 16:37:56 UTC
Sounds conclusive, re-assigning. Lukas, can you take care of this?

Comment 10 Lukas Vrabec 2017-10-26 18:07:50 UTC
Sure I can, builds will be available in hour.

Comment 11 Fedora Update System 2017-10-26 18:49:31 UTC
selinux-policy-3.13.1-283.14.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b5e9ce60d2

Comment 12 Adam Williamson 2017-10-26 20:39:20 UTC
Discussed at 2017-10-26 Fedora 27 Final go/no-go meeting, acting as a freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-10-26/f27-final-and-server-beta-go-no-go-meeting.2017-10-26-17.00.html . Accepted as a freeze exception issue, this is quite bad for affected users and cannot be fully fixed with an update.

Comment 13 Fedora Update System 2017-10-27 18:47:45 UTC
selinux-policy-3.13.1-283.14.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b5e9ce60d2

Comment 14 Fedora Update System 2017-10-31 15:38:45 UTC
selinux-policy-3.13.1-283.14.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Adam Williamson 2017-11-14 01:55:52 UTC
No longer needs commonbugs, as it's fixed.


Note You need to log in before you can comment on or make changes to this bug.