Bug 1499380 - [abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
Summary: [abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_err...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1bc74610c94cfae83f285677985...
: 1548254 1565440 1567692 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-06 21:31 UTC by Carlos O'Donell
Modified: 2018-04-30 04:45 UTC (History)
29 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:28:06 UTC


Attachments (Terms of Use)
File: backtrace (2.08 KB, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: cgroup (289 bytes, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: cpuinfo (1.36 KB, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: environ (1.63 KB, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: mountinfo (3.13 KB, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: namespaces (102 bytes, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details
File: open_fds (867 bytes, text/plain)
2017-10-06 21:31 UTC, Carlos O'Donell
no flags Details

Description Carlos O'Donell 2017-10-06 21:31:25 UTC
Description of problem:
Right clicked on docked dnfdragora icon, clicked updated.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.3-301.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 236, in inner
    callback(self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 320, in __call__
    return self._action(icon, self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 414, in wrapper1
    return action(icon)
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 113, in __run_update
    return self.__run_dialog({'update_only': True})
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 104, in __run_dialog
    self.__main_gui = ui.mainGui(args)
  File "/usr/lib/python3.6/site-packages/dnfdragora/ui.py", line 214, in __init__
    rpm_groups = self.backend.GetGroups()
  File "/usr/lib/python3.6/site-packages/dnfdragora/basedragora.py", line 50, in backend
    return self.get_root_backend()
  File "/usr/lib/python3.6/site-packages/dnfdragora/basedragora.py", line 77, in get_root_backend
    self.backend.ExpireCache()
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 401, in ExpireCache
    rc = self._run_dbus_async('ExpireCache', '()')
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 293, in _run_dbus_async
    result = self._get_result(data)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 277, in _get_result
    self._handle_dbus_error(user_data['error'])
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 250, in _handle_dbus_error
    raise DaemonError(str(err))
dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Local variables in innermost frame:
msg: ''
exc: ''
err: GLib.Error('GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application', 'g-io-error-quark', 36)
self: <dnfdragora.dnf_backend.DnfRootBackend object at 0x7f84da9ee898>

Potential duplicate: bug 1472678

Comment 1 Carlos O'Donell 2017-10-06 21:31:29 UTC
Created attachment 1335540 [details]
File: backtrace

Comment 2 Carlos O'Donell 2017-10-06 21:31:30 UTC
Created attachment 1335541 [details]
File: cgroup

Comment 3 Carlos O'Donell 2017-10-06 21:31:31 UTC
Created attachment 1335542 [details]
File: cpuinfo

Comment 4 Carlos O'Donell 2017-10-06 21:31:33 UTC
Created attachment 1335543 [details]
File: environ

Comment 5 Carlos O'Donell 2017-10-06 21:31:34 UTC
Created attachment 1335544 [details]
File: mountinfo

Comment 6 Carlos O'Donell 2017-10-06 21:31:35 UTC
Created attachment 1335545 [details]
File: namespaces

Comment 7 Carlos O'Donell 2017-10-06 21:31:36 UTC
Created attachment 1335546 [details]
File: open_fds

Comment 8 Joshua Malone 2017-10-23 04:37:41 UTC
*** Bug 1505224 has been marked as a duplicate of this bug. ***

Comment 9 David 2017-11-17 09:29:09 UTC
Similar problem has been detected:

Problem occured during system startup.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 hbmat1958 2017-11-20 12:35:53 UTC
Similar problem has been detected:

The proble start when this progrm is second or third started. It just would not proceed.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.9-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 11 aannoaanno 2017-11-22 18:01:42 UTC
*** Bug 1516490 has been marked as a duplicate of this bug. ***

Comment 12 ricky.tigg 2017-11-23 07:56:20 UTC
Similar problem has been detected:

While using dnfdragora search tool, no matter the target, dnfdragora remains unresponsive  and very often freezes. In that condition the application cannot be closed conventionally but using the System monitor.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 13 Marcin 2017-11-26 00:27:58 UTC
Similar problem has been detected:

simply click to check for updates and error reportin tool popped up.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 14 Alan Olsen 2017-11-26 22:44:31 UTC
A quick workaround is to run "dnfdragora --exit".

The same problem existed in yumex-dnf in F26.

Comment 15 Steve 2017-11-28 15:25:21 UTC
*** Bug 1518305 has been marked as a duplicate of this bug. ***

Comment 16 Richard L. England 2017-12-04 00:44:21 UTC
Similar problem has been detected:

Unknown. 

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 17 Sam Tygier 2017-12-08 15:05:52 UTC
Similar problem has been detected:

On clicking "Update" in the panel applet

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.16-302.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 18 Eduardo Amaral Ferreira 2017-12-11 00:51:06 UTC
*** Bug 1524226 has been marked as a duplicate of this bug. ***

Comment 19 Orion Caspar 2017-12-11 12:36:45 UTC
*** Bug 1524401 has been marked as a duplicate of this bug. ***

Comment 20 aekryz 2017-12-18 14:30:00 UTC
*** Bug 1527087 has been marked as a duplicate of this bug. ***

Comment 21 aekryz 2017-12-18 14:34:31 UTC
*** Bug 1527090 has been marked as a duplicate of this bug. ***

Comment 22 Dave Peek 2017-12-19 16:48:12 UTC
*** Bug 1527631 has been marked as a duplicate of this bug. ***

Comment 23 Hayden 2017-12-21 19:55:11 UTC
*** Bug 1528424 has been marked as a duplicate of this bug. ***

Comment 24 David 2017-12-22 14:49:40 UTC
Similar problem has been detected:

I tried to open the dialog. Nothing other copy of DNF was running at the moment.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /bin/dnfdragora-updater
kernel:         4.14.7-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 25 Leszek Matok 2017-12-23 21:54:20 UTC
Similar problem has been detected:

It's some new program with permanent icon in Cinnamon, I opened it, had no idea what it's supposed to do really, so I closed its window and it crashed.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.7-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 26 ricky.tigg 2017-12-27 11:11:00 UTC
*** Bug 1529261 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2017-12-29 23:23:01 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 28 Fedora Update System 2017-12-29 23:27:35 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 29 Fedora Update System 2017-12-30 19:54:30 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 30 Fedora Update System 2017-12-30 20:40:15 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 31 Fedora Update System 2017-12-31 21:28:06 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2018-01-01 22:11:44 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Douglas 2018-01-04 11:35:04 UTC
*** Bug 1530985 has been marked as a duplicate of this bug. ***

Comment 34 Peter Brown 2018-02-23 03:03:49 UTC
*** Bug 1548254 has been marked as a duplicate of this bug. ***

Comment 35 Dipak Patil 2018-04-10 02:46:35 UTC
*** Bug 1565440 has been marked as a duplicate of this bug. ***

Comment 36 Ali 2018-04-15 13:41:10 UTC
Hello Guys. Here is a SOLUTION; its stupid but it works

- Select Applications Menu (Top Left Corner).
- Select Administration > dnfdragora-updater
- Software Management Icon (Yellow Cuboid)appears next to the clock on the Top Right corner.
- Right Click (Ctrl Click) on the Yellow Cuboid (Icon).
- Then select Open dnfdragora dialogue (the application freezes at this point.Give it a couple of seconds or a minute).
- Right Click (Ctrl Click) the Yellow Cuboid (Icon) again.
- Select Exit.
- Go back to the Applications Menu (Top Left Corner).
- Select Administration > dnfdragora (Not the updater).
- Software Management opens successfully (Give it some time to load Fedora Updates)

Test the application by typing something like Tor Browser (Make sure the search filters are set to All > All > In Summaries) then click Search.

Thank you.

Comment 37 Aang Andhika 2018-04-16 02:09:31 UTC
*** Bug 1567692 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.