Bug 149942 - gfs_fsck: Resource group is corrupted
Summary: gfs_fsck: Resource group is corrupted
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: AJ Lewis
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-28 21:45 UTC by Corey Marthaler
Modified: 2010-01-12 03:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 17:09:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2005-02-28 21:45:08 UTC
Description of problem:
According to AJ, it happens when a block is marked as metadata, but
the FLAG on the inode is ip->i_di.di_flags & GFS_DIF_UNUSED.

.
.
.
Found unused inode marked in-use
Found unused inode marked in-use
Found unused inode marked in-use
Found unused inode marked in-use
Checking metadata in Resource Group 1215
Buffer #79574498 (1 of 5) is neither GFS_METATYPE_RB nor GFS_METATYPE_RG.
Resource group is corrupted.
[root@morph-03 ~]# echo $?
1

Version-Release number of selected component (if applicable):
GFS 2.6.9-23.10 (built Feb 24 2005 17:20:27) installed

Comment 1 AJ Lewis 2005-03-02 16:32:00 UTC
The 'Found unused inode marked in-use' is unrelated.  There was a SCSI error in
the same time-frame as this corruption - I'm guessing that's what caused it. 
The only way the fsck could have corrupted this resource group is if it was run
twice in a row, and this was the beginning of the second run.

Comment 2 AJ Lewis 2005-04-05 17:09:41 UTC
Marking this notabug since we can't reproduce it and QA was having all kinds of
issues with storage at the time.  If it crops up again it can be reopened.


Note You need to log in before you can comment on or make changes to this bug.