Bug 1499534 - dnf-2 is much slower than dnf-1 when handling groups
Summary: dnf-2 is much slower than dnf-1 when handling groups
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-08 13:05 UTC by Davide Repetto
Modified: 2017-11-11 02:54 UTC (History)
8 users (show)

Fixed In Version: dnf-2.7.4-1.fc26 dnf-2.7.4-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 23:11:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Davide Repetto 2017-10-08 13:05:18 UTC
Description of problem:
dnf-2 is much slower than dnf-1 when handling groups And a few other things. Way much slower.

Version-Release number of selected component (if applicable):
=============================================================
dnf-2.7.3-1.fc27.noarch

How reproducible:
=================
I'm experiencing it with quite simple installations with mate-desktop.
Some of them are brand new fc27 machines, some others are machines that
I upgraded with dnf from fc26.

I noticed this first on the machines I upgraded because I usually follow the upgrades with some cleanups that include the following:

# dnf groups mark remove \*   # does not work properly on DNF-2
# So we have to mark the groups one by one 
dnf groups mark remove minimal-environment
dnf groups mark remove custom-environment
dnf groups mark remove base-x
dnf groups mark remove mate-desktop-environment
dnf groups mark remove mate-applications
dnf groups mark remove mate-compiz
dnf groups mark remove core

# Install whatever is missing and implicitly mark packages as installed
# with the group they belog to.
dnf -y install @minimal-environment @custom-environment @base-x  \
               @mate-desktop-environment @mate-applications      \
               caja-beesu                                        \
               --exclude mate-menus-preferences-category-menu    \
               --exclude caja-terminal                           \
               --exclude cinna\*  --exclude @cinna\*             \
               --exclude kde\* --exclude kf5\*                   \
               --allowerasing --exclude kernel\*


Under fc27 the latter takes *several* minutes just to resolve the packages list, while with f25 (on the same hardware) it consistently does it in a matter of seconds.


====================== Execution Under fc25 ============================

# export LANG=C ; time dnf -y install @... (see above for the full command)

Last metadata expiration check: 3:50:21 ago on Sun Oct  8 09:30:22 2017.
Environment 'Minimal Install' is already installed, skipping.
Environment 'Fedora Custom Operating System' is already installed, skipping.
Group 'base-x' is already installed, skipping.
Environment 'MATE Desktop' is already installed, skipping.
Group 'MATE Applications' is already installed, skipping.
Package caja-beesu-1.18.1-1.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

real	0m4.855s
user	0m4.015s
sys	0m0.209s


====================== Execution Under fc27 ============================

# export LANG=C ; time dnf -y install @... (see above for the full command)

Last metadata expiration check: 0:19:58 ago on Sun Oct  8 14:11:47 2017.
Environment 'Minimal Install' is already installed.
Group 'Core' is already installed.
Environment 'Fedora Custom Operating System' is already installed.
Group 'Core' is already installed.
Group 'base-x' is already installed.
Environment 'MATE Desktop' is already installed.
Group 'base-x' is already installed.
Group 'Standard' is already installed.
Group 'Core' is already installed.
Group 'Administration Tools' is already installed.
Group 'Dial-up Networking Support' is already installed.
Group 'Fonts' is already installed.
Group 'Input Methods' is already installed.
Group 'Multimedia' is already installed.
Group 'Common NetworkManager Submodules' is already installed.
Group 'Hardware Support' is already installed.
Group 'Printing Support' is already installed.
Group 'Guest Desktop Agents' is already installed.
Group 'MATE' is already installed.
Group 'MATE Applications' is already installed.
Package caja-beesu-1.18.1-4.fc27.x86_64 is already installed, skipping.
No match for group package "gstreamer1-plugins-bad"
No match for group package "rfremix-logos"
No match for group package "ubuntu-font-family"
No match for group package "caja-terminal"
No match for group package "xorg-x11-drv-omap"
No match for group package "workaround-cyrillic-console"
No match for group package "mate-menus-preferences-category-menu"
No match for group package "kmod-samsung-backlight"
No match for group package "xorg-x11-drv-armsoc"
No match for group package "kmod-rt3090"
No match for group package "rfremix-release"
No match for group package "kmod-rt3062"
No match for group package "kmod-brcm80211"
No match for group package "madwimax"
No match for group package "kernel-modules-extra"
Dependencies resolved.
Nothing to do.
Complete!

real    15m7.784s
user    14m51.222s
sys     0m1.498s

Comment 1 Jaroslav Mracek 2017-10-10 07:35:10 UTC
The first part of the problem will be fixed by https://github.com/rpm-software-management/libdnf/pull/338

Comment 2 Jaroslav Mracek 2017-10-10 09:21:50 UTC
A create a patch (https://github.com/rpm-software-management/dnf/pull/948) that with the patch mentioned above reduce time required for the command to 6 s.

Comment 3 Jaroslav Mracek 2017-10-10 16:23:05 UTC
*** Bug 1500370 has been marked as a duplicate of this bug. ***

Comment 4 Jaroslav Mracek 2017-10-11 10:52:12 UTC
*** Bug 1500361 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2017-10-16 09:05:55 UTC
dnf-2.7.4-1.fc26 libdnf-0.11.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f04c2c90f

Comment 6 Fedora Update System 2017-10-16 09:06:53 UTC
dnf-2.7.4-1.fc27 libdnf-0.11.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-113a221a3d

Comment 7 Fedora Update System 2017-10-16 18:23:01 UTC
dnf-2.7.4-1.fc26, libdnf-0.11.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f04c2c90f

Comment 8 Fedora Update System 2017-10-17 02:24:34 UTC
dnf-2.7.4-1.fc27, libdnf-0.11.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-113a221a3d

Comment 9 Fedora Update System 2017-10-25 23:11:29 UTC
dnf-2.7.4-1.fc26, libdnf-0.11.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-11-11 02:54:48 UTC
dnf-2.7.4-1.fc27, libdnf-0.11.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.