Bug 1499570 - Blank screen on new AMD Radeon RX 500 series and possibly Vega
Blank screen on new AMD Radeon RX 500 series and possibly Vega
Status: CLOSED DUPLICATE of bug 1499580
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
27
All Linux
high Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-08 14:52 EDT by Luya Tshimbalanga
Modified: 2017-10-28 06:38 EDT (History)
43 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-10 21:16:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Journal from booting with AMD Radeon RX 560 (646.83 KB, text/plain)
2017-10-09 18:41 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2017-10-08 14:52:29 EDT
Description of problem:
New AMD Radeon RX 500 series seems not yet supported on Fedora resulting to blank screen although the system correctly detected the card. According to a test from Phoronix website (https://www.phoronix.com/scan.php?page=article&item=radeon-rx-560&num=1), llvm 5.0 is required but currently missing in the main repository save a failed build (https://koji.fedoraproject.org/koji/buildinfo?buildID=979610) despite latest stable mesa 17.2 and amdgpu driver. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora with new AMD Radeon RX 500 series or Vega
2.
3.

Actual results:
Blank screen

Expected results:
Graphical boot to login screen

Additional info:
Workaround is to use nomodeset parameter to boot or possibly installing amdgpu-pro which requires a downgraded xserver
Comment 1 Luya Tshimbalanga 2017-10-08 20:33:45 EDT
Assigning to the right package as it turned out a custom kernel from COPR repository (https://copr.fedorainfracloud.org/coprs/mystro256/amd-staging-kernel/) based on https://cgit.freedesktop.org/~agd5f/linux/ resolved the blank screen issue which provides the missing components needed for new Radeon RX cards.
Comment 2 Kamil Páral 2017-10-09 04:15:59 EDT
You need to provide at least a journal from the failed boot if anyone is to be able to debug anything. LLVM 5.0 should not be required for R5xx series, as far as I know.
Comment 3 Luya Tshimbalanga 2017-10-09 18:41 EDT
Created attachment 1336581 [details]
Journal from  booting with AMD Radeon RX 560

It was very difficult to get a journal report because the blank screen immediately occurred after choosing the kernel from boot.
Comment 4 Kamil Páral 2017-10-10 07:30:49 EDT
I'm seeing some crashes:

Oct 08 16:00:24 kwetu.telus3226 kernel: disasm.x86[3091]: segfault at f573f52c ip 0000000008b9d53b sp 00000000ff8f2020 error 4 in disasm.x86[8048000+184a000]
Oct 08 16:43:49 kwetu.telus3226 kernel: gfxbench_gl[4069]: segfault at c ip 000000000069a9f5 sp 00007f040ad0e090 error 4 in gfxbench_gl[400000+686000]
Oct 08 16:44:09 kwetu.telus3226 kernel: gfxbench_gl[4173]: segfault at c ip 000000000069a9f5 sp 00007f90aed0e090 error 4 in gfxbench_gl[400000+686000]

but not much anything else. Kernel folks need to look at this.

> It was very difficult to get a journal report because the blank screen
> immediately occurred after choosing the kernel from boot.

Remove rhgb quiet from kernel cmdline, boot. Let it run for a while, so that logs are synced to disk. Then reboot it, boot with nomodeset (so that you get a working boot), and access the journal from the previous boot using `journalctl -b -1`. But since the log is here, I see you managed to do it somehow :)
Comment 5 Laura Abbott 2017-10-10 10:32:43 EDT
Assigning to the graphics team to identify the correct components to bring in. If someone states the specific patches we can bring them in.
Comment 6 pete.marchingcubes 2017-10-10 15:32:57 EDT
I filed a similar bug https://bugzilla.redhat.com/show_bug.cgi?id=1499580

It looks to me like there is a problem loading firmware or otherwise initialising the card from the initrd, which is not evident when modprobing the driver from the main system.

The amdgpu module can be loaded and run the display without a problem if it is modprobed after the kernel has booted (I do this my passing modprobe.blacklist=amdgpu to the kernel, and modprobing amdgpu after boot.

Note this discrepancy:

lsinitrd /mnt/initrd_debug/initramfs-4.13.4-200.fc26.x86_64.img |grep polaris11
-rw-r--r--   2 root     root         8832 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_ce.bin
-rw-r--r--   1 root     root       130228 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_k_smc.bin
-rw-r--r--   1 root     root        32724 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_mc.bin
-rw-r--r--   1 root     root        17024 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_me.bin
-rw-r--r--   2 root     root       262784 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_mec2.bin
-rw-r--r--   2 root     root            0 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_mec.bin
-rw-r--r--   1 root     root        17024 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_pfp.bin
-rw-r--r--   1 root     root        23184 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_rlc.bin
-rw-r--r--   2 root     root        12692 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_sdma1.bin
-rw-r--r--   2 root     root        12692 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_sdma.bin
-rw-r--r--   1 root     root       130196 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_smc.bin
-rw-r--r--   1 root     root       130196 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_smc_sk.bin
-rw-r--r--   3 root     root            0 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_uvd.bin
-rw-r--r--   3 root     root            0 Aug 12 00:19 usr/lib/firmware/amdgpu/polaris11_vce.bin

ls /lib/firmware/amdgpu/ -l |grep polaris11
-rw-r--r--. 1 root root   8832 Sep 21 01:05 polaris11_ce.bin
-rw-r--r--. 1 root root 130228 Sep 21 01:05 polaris11_k_smc.bin
-rw-r--r--. 1 root root  32724 Sep 21 01:05 polaris11_mc.bin
-rw-r--r--. 1 root root  17024 Sep 21 01:05 polaris11_me.bin
-rw-r--r--. 1 root root 262784 Sep 21 01:05 polaris11_mec2.bin
-rw-r--r--. 1 root root 262784 Sep 21 01:05 polaris11_mec.bin
-rw-r--r--. 1 root root  17024 Sep 21 01:05 polaris11_pfp.bin
-rw-r--r--. 1 root root  23184 Sep 21 01:05 polaris11_rlc.bin
-rw-r--r--. 1 root root  12692 Sep 21 01:05 polaris11_sdma1.bin
-rw-r--r--. 1 root root  12692 Sep 21 01:05 polaris11_sdma.bin
-rw-r--r--. 1 root root 130196 Sep 21 01:05 polaris11_smc.bin
-rw-r--r--. 1 root root 130196 Sep 21 01:05 polaris11_smc_sk.bin
-rw-r--r--. 1 root root 369696 Sep 21 01:05 polaris11_uvd.bin
-rw-r--r--. 1 root root 166816 Sep 21 01:05 polaris11_vce.bin


polaris11_mec.bin in the initird firmware image has a zero length, along with the polaris11_uvd.bin and usr/lib/firmware/amdgpu/polaris11_vce.bin. I think this may be the problem?
Comment 7 Luya Tshimbalanga 2017-10-10 18:35:26 EDT
*** Bug 1499580 has been marked as a duplicate of this bug. ***
Comment 8 pete.marchingcubes 2017-10-10 21:05:56 EDT
This bug description is awful. if youre going to mark my bug as a dupe, at least try to be clearer about the problem, without mentioning LLVM, phoronix etc.

No maintainer is going to look at this and take it seriously.
Comment 9 Dave Airlie 2017-10-10 21:11:49 EDT
There is no upstream kernel support for AMD Vega. There won't be before 4.15.
Comment 10 Luya Tshimbalanga 2017-10-10 21:16:59 EDT
Closing this bug as duplicate and assigning to #1499580.

*** This bug has been marked as a duplicate of bug 1499580 ***

Note You need to log in before you can comment on or make changes to this bug.