Bug 149968 - ipw2100 wifi driver dies at random
ipw2100 wifi driver dies at random
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
http://www.bughost.org/bugzilla/show_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 20:57 EST by uche.ogbuji
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 14:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description uche.ogbuji 2005-02-28 20:57:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
Problem machine is a Dell Inspiron 8600 running on Fedora Core 3.  The
wireless card is an Intel 2100.  I was running ipw2100-0.54 (I shared my recipe
<a href="http://www.oreillynet.com/pub/wlg/5690">here</a>) in kernel 2.6.9 with
no problems as a separate download/install.  Recently I made a routine update, which bumped me up to kernel "2.6.10-1.766_FC3".  I noticed that Fedora
now bundles the ipw2100 driver, so I didn't repeat the separate driver install.

Now, however, I am seeing a known problem ( http://www.bughost.org/bugzilla/show_bug.cgi?id=245 ) with this driver.  Specifically every 10 minutes or so the driver flakes out and my network connection dies until I restart it.  Sometimes I get
the dreaded device message "ipw2100: ipw2100: Fatal interrupt. Scheduling firmware restart."  Signal strength to the AP is fine.  When the connection dies one of the suggested workarounds, "iwlist eth0 scan" doesn't seem to restore the network.  I have to do "ifdown eth0; ifup eth0".

I see that kernel-2.6.10-1.766_FC3 includes version 1.0.0 of ipw2100.  The project is up to version 1.0.5, and 1.0.4 incluides a workaround for this bug, thought there is not yet a proper fix.  Could you please upgrade the ipfw2100 version that comes with FC3 kernels?  I notice that others have made the same request in order to address other bugs ( e.g. https://bugzilla.redhat.com/beta/show_bug.cgi?id=144926 ).


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install ipw2100 card
2. Wait for network to die
3. Restart network
4. Wait for it to die again
  

Actual Results:  Network died, and kept dying.

Expected Results:  Netowrk should work fine.

Additional info:
Comment 1 Dave Jones 2005-07-15 15:29:19 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 uche.ogbuji 2005-07-16 09:22:54 EDT
Yes, I upgraded to FC4 (of course :-) ), and the problem persists, although with
much lower frequency (every few days now, which is tolerable).  The big
improvement came when I replaced my access point, however, rather than the
upgrade to FC4.  I do believe that the former frequency of the problem was the
result ogf a bug in the AP triggering a bug in the kernel.  Anyway, my updated
kernel version is 2.6.11-1.1369_FC4.  I see that 2.6.12-1.1398_FC4 is now out. 
I shall try that and report back, though it may take a few days because I have
to see that it stays alive long enough.  Thanks.
Comment 3 Dave Jones 2005-11-10 14:03:42 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 4 Kenneth Ahn Jensen 2005-12-02 15:39:18 EST
I have just tested with both kernels 2.6.13-1.1526_FC4 and 2.6.14-1.1644_FC4,
and the problem still exists. I just upgraded the kernel now to check if it
helped, but no such luck. 

My environment: 
I'm sitting in an office building where the laptop can "see" 3 different AP's on
the same network/SSID - one is quite strong (signal 70/100), and the other two
are quite weak (signal 10-25/100).

The connection dies very quickly if I utilise it, say by rsyncing a lot of data
across the wireless net, and then the error message "ipw2100: fatal interrupt,
scheduling firmware restart" starts cluttering my dmesg-buffer.

Cheers,
Kenneth
Comment 5 John W. Linville 2005-12-02 15:57:42 EST
The Fedora-netdev kernels are available here: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give those a try to see if any later patches help this issue, and post 
the results here...thanks! 
 
BTW, please also make sure you are using the latest firmware from the 
sourceforge project's page: 
 
   http://ipw2100.sourceforge.net/firmware.php 
Comment 6 John W. Linville 2006-01-09 14:30:54 EST
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 
Comment 7 Daniel L. Rall 2006-04-15 02:54:59 EDT
I'm seeing similar symptoms with a "Intel Corporation PRO/Wireless LAN 2100 3B
Mini PCI Adapter (rev 04)" Thinkpad T-41 on Fedora Core 4.  Around the time of
the crash ("fixable" per the original comment in this issue with ifup/ifdown iff
I'm right next to my access point), I get the following in /var/log/messages:

Apr 12 08:59:55 localhost kernel: ipw2100: ipw2100: Fatal interrupt. Scheduling
firmware restart.

I've tried the following kernels, all of which exhibit this problem:

2.6.16-1.2069_FC4
2.6.12-1.1390_FC4
2.6.11-1.1369_FC4
Comment 8 Daniel L. Rall 2006-04-15 02:59:05 EDT
I've got the ipw2100 1.3 firmware installed.
Comment 9 Daniel L. Rall 2006-04-15 03:07:25 EDT
FWIW, most of the packages on my Fedora Core 4 installed have been updated to
the latest stable release available (via yum).

I believe I've provided a response to the last question by Dave Jones.  I
request that this bug be REOPENED.  Note that the corresponding upstream ipw2100
bug remains ASSIGNED (open) as well:

http://www.bughost.org/bugzilla/show_bug.cgi?id=245

I don't particularly relish the idea of installed a netdev kernel on this
machine (suggested by John Linville), as I use it for the day job.  Is there
anything else I can do to help?

Thanks, Dan
Comment 10 Daniel L. Rall 2006-04-15 03:42:35 EDT
At a superficial level, upstream bug
<http://www.bughost.org/bugzilla/show_bug.cgi?id=329> appears related, too. 
(It's also documented as a known issue by Intel in their ipw2100 driver release
tarball.)

Note You need to log in before you can comment on or make changes to this bug.