Bug 149976 - spec file changelog date format is overly restrictive
Summary: spec file changelog date format is overly restrictive
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-01 04:01 UTC by Mike Pope
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-03 11:46:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Pope 2005-03-01 04:01:42 UTC
Description of problem: The %changelog date format disallows dates
before 1997.  Fair enough for RedHat packages perhaps, but it
surprised me when I aggregated some old changelogs for one of my
projects into a spec file.  The offending line of code is in
build/parseChangelog.c:
   if (time.tm_year < 1997 || time.tm_year >= 3000) return -1;
Its trivial, and looks pretty safe to relax this, say to a more
unix-epoch-like 1970, although all the way to 1900 may well be ok.

Version-Release number of selected component (if applicable): rpm-4.3.2-21

How reproducible: Reliable.

Steps to Reproduce:
1. Put a line with a date pre-1997 in a spec file changelog.
2. Build rpm.
 
Actual results:
error: bad date in %changelog: Thu Jan 05 1995 Michael Pope

Expected results:
It should just work:-).

Additional info:

Comment 1 Jeff Johnson 2005-03-03 11:46:10 UTC
No rpm package existed before 1997 because rpm had not been
written.

While relaxing the restriction is quite easy to implement,
it will cause build failures with versions of rpm that do
not have the same (overly restrictive) policy.

I'll make the change in CVS head but it will be quite
a few years before a less restrictive date check is
widley deployed.


Note You need to log in before you can comment on or make changes to this bug.