Bug 150001 - Wrong description of telnet-server
Wrong description of telnet-server
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: specspo (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernd Groh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 10:05 EST by Radek Bíba
Modified: 2014-06-18 04:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 02:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2005-03-01 10:05:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
`rpm -qi telnet-server` says that "The telnet daemon is disabled by
default. You may enable the telnet daemon by editing
/etc/xinetd.d/telnet." But it's not true. The default behavior has
changed, as changelog says:

* Fri Dec 01 2000 Trond Eivind Glomsrd <teg@redhat.com>

- make sure the server is turned off by default

So it seems somebody forgot to change the description. BTW, the wrong
description is in other languages, too.

Version-Release number of selected component (if applicable):
telnet-server-0.17-20

How reproducible:
Always

Steps to Reproduce:
1. install telnet-server
2. check to see if telnet daemon is up and running
 (e.g. "netstat -l --inet" or "telnet localhost")

Actual Results:  In fact, that's not a bug that the telnet daemon
doesn't run. What is wrong is the description.

Expected Results:  Package description shouldn't lie :)

Additional info:

The description is wrong not only in RHEL 2.1 on an i386, but also in
RHEL 3, 4 and Fedora Core 3. Users of other RPM-based distros may
also possibly confirm this wrong description.
Comment 1 Suzanne Hillman 2005-03-03 16:18:09 EST
...

Am I to guess that your description is backward?

Because the way you described it, it's disabled by default, which as far as I
can tell is what the changelog says...
Comment 2 Harald Hoyer 2005-03-04 07:21:02 EST
the description on AS2.1 is wrong.. it says, that the daemon is enabled by default
Comment 3 Radek Bíba 2005-03-04 07:54:31 EST
Damn! I wonder how could I do the mistake in my description of this bugzilla
entry and didn't notice it??? `rpm -qi telnet-server` *really* says:

(blah blah...) The telnet daemon is
enabled by default. You may disable the telnet daemon by editing
/etc/xinetd.d/telnet.

You can verify it yourself. Sorry for that confusion. (if only I could edit it)
Comment 4 Harald Hoyer 2005-05-02 11:35:24 EDT
$ LANG=C rpm -qpi telnet-server-0.17-20.EL2.3.i386.rpm
... The telnet daemon is
disabled by default. You may enable the telnet daemon by editing
/etc/xinetd.d/telnet.

Now, specspo needs to be fixed

Note You need to log in before you can comment on or make changes to this bug.