Bug 1500106 - subscription-manager status --ondate=2099-12-25 is not passing the date to candlepin
Summary: subscription-manager status --ondate=2099-12-25 is not passing the date to ca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-09 21:38 UTC by John Sefler
Modified: 2018-04-10 09:52 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.20.6-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github /candlepin subscription-manager pull 1722 None None None 2017-11-08 21:52:27 UTC
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:52:27 UTC

Description John Sefler 2017-10-09 21:38:34 UTC
Description of problem:


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.1-1.git.74.728e0c3.el7
python-rhsm: 1.20.1-1.git.75.728e0c3.el7


How reproducible:


Steps to Reproduce:
After successfully registering and attaching an entitlement, run the following on the command line while simultaneously tailing the rhsm.log as follows...


[root@jsefler-rhel7 ~]# subscription-manager status --ondate=2099-12-25
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current


[root@jsefler-rhel7 ~]# tail -f /var/log/rhsm/rhsm.log | grep GET
2017-10-09 17:28:12,504 [DEBUG] subscription-manager:5008:MainThread @connection.py:515 - Making request: GET /subscription/consumers/0438e90c-69ba-4f85-8b89-3e75fab1305b/compliance
2017-10-09 17:28:13,053 [INFO] subscription-manager:5008:MainThread @connection.py:556 - Response: status=200, requestUuid=87764027-041c-4385-be8f-e60bc03c287a, request="GET /subscription/consumers/0438e90c-69ba-4f85-8b89-3e75fab1305b/compliance"

Actual results:
  Making request: GET /subscription/consumers/0438e90c-69ba-4f85-8b89-3e75fab1305b/compliance

Expected results:
  Making request: GET /subscription/consumers/0438e90c-69ba-4f85-8b89-3e75fab1305b/compliance?on_date=2099-12-25T00%3A00%3A00


Unless Red Hat renews my current subscription with a lifetime subscription, I expect that on 2099-12-25, my system status will be...
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

Red Hat Enterprise Linux Server:
- Not supported by a valid subscription.

Comment 3 Shwetha Kallesh 2017-11-29 10:21:23 UTC
verification:
[root@dhcp35-10 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.7-1.el7


Verify the subscription end date in the consumed list:

[root@dhcp35-10 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name:   Admin OS Instance Based one socket
Provides:            Awesome OS Instance Server Bits
                     Admin OS Premium Architecture Bits
                     Admin OS Developer Bits
SKU:                 adminos-onesocketib
Contract:            1
Account:             12331131231
Serial:              3739895884981493785
Pool ID:             8ac6a3625fd92546015fd92618d103c6
Provides Management: No
Active:              True
Quantity Used:       1
Service Level:       Standard
Service Type:        L1-L3
Status Details:      Guest has not been reported on any host and is using a temporary unmapped guest subscription.
Subscription Type:   Instance Based (Temporary)
Starts:              11/20/2017
Ends:                12/06/2017               ----> ends by Dec 12 2017
System Type:         Virtual

Check the current status ,observe its insufficient:

[root@dhcp35-10 ~]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Insufficient

Admin OS Instance Based one socket:
- Guest has not been reported on any host and is using a temporary unmapped guest subscription.


Now check the status of the system on 2099-12-25 , its invalid , as subscription doesnot cover by 2099, so marking bug as verified

[root@dhcp35-10 ~]# subscription-manager status --ondate=2099-12-25
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

Awesome OS Instance Server Bits:
- Not supported by a valid subscription.

Comment 6 errata-xmlrpc 2018-04-10 09:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.