Bug 150017 - evolution no longer queries LDAP for contacts
evolution no longer queries LDAP for contacts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 12:46 EST by Shahms E. King
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 16:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahms E. King 2005-03-01 12:46:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
After upgrading to the test update of evolution-2.0.4 and evolution-data-server-1.0.4 contact queries against an LDAP addressbook no longer work.  The queries and autocompletion worked flawlessly prior to the update.

Version-Release number of selected component (if applicable):
2.0.4

How reproducible:
Always

Steps to Reproduce:
1. Set up a LDAP addressbook
2. Click On "Contacts" or compose a new email
3. Search for a known entry in the LDAP addressbook

  

Actual Results:  No results are returned. Ever.

Expected Results:  At least one matching entry should be listed in the contacts or the autocomplete drop down should show up.

Additional info:

Occasionally, the following entries show up in xsession errors:

eab-widgets-Message: in search_activated

(evolution:10305): e-utils-WARNING **: Error in parsing: Unknown identifier: match-all

(evolution:10305): e-utils-CRITICAL **: file e-sexp.c: line 1297 (e_sexp_eval): assertion `f->tree != NULL' failed
(evolution:10305): libebook-WARNING **: conversion to EBookQuery failed
eab-widgets-Message: in search_activated

(evolution:10305): e-utils-WARNING **: Error in parsing: Unknown identifier: match-all

`f->tree != NULL' failed
(evolution:10305): libebook-WARNING **: conversion to EBookQuery failed
Comment 1 Shahms E. King 2005-03-29 16:39:23 EST
This appears to be fixed in the most recent evolution.
Comment 2 Dave Malcolm 2005-03-30 13:06:53 EST
Please can you clarify exactly which evolution package you're referring to in
comment #1?  Thanks.
Comment 3 Shahms E. King 2005-03-30 14:02:42 EST
Comment #1 was referring to evolution-2.0.4-2.

However, I spoke too soon.  The LDAP server was upgraded about the same time as
evolution and I'm pretty sure it was the LDAP upgrade that fixed it. OpenLDAP
changed how it matches objectClass in queries between 2.0 and 2.2.  The slaves
were upgrade to 2.2, while the master is still at 2.0.  Queries against the
slaves work but fail against the master.  I'm not sure if this is something that
needs to be fixed in evolution, but due to the stricter schema checking in
OpenLDAP 2.2 upgrading isn't always easy.

Comment 4 Dave Malcolm 2005-03-30 19:23:35 EST
Thanks - that's useful information.

So would it be accurate to retitle this bug as:
"evolution's addressbook's LDAP backend doesn't work with an OpenLDAP 2.2 server
(did with 2.0)"
Comment 5 Shahms E. King 2005-03-30 21:03:47 EST
No, it works with OpenLDAP 2.2.  The problem (I think) is that we have a
MESDperson (or similar) object class that derives from 'person' and OpenLDAP 2.0
doesn't match derived object classes to queries against their base, whereas
OpenLDAP 2.2 does.  I'm not sure which is correct, but I think it's OpenLDAP 2.2.

I'm not sure why it broke between evolution 2.0.2 and 2.0.4 (unless evo only
recently started adding 'objectClass=person' to the LDAP query...)
Comment 6 Serge 2005-04-21 01:37:47 EDT
I have the same problem, except that I only get 
eab-widgets-Message: in search_activated
on the console. The stop button and the find button are greyed out
Running 
 openldap 2.2 
 evolution-2.0.4-2
 evolution-data-server-1.0.4-3 

Downgrading to 
 evolution-2.0.2-3
 evolution-data-server-1.0.2-3

Fixes it


Note You need to log in before you can comment on or make changes to this bug.