Bug 150028 - libmatroska Requires: libebml-devel
Summary: libmatroska Requires: libebml-devel
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libmatroska   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-01 20:13 UTC by Jeff Moe (jebba)
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 15:37:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Moe (jebba) 2005-03-01 20:13:33 UTC
Description of problem:
libmatroska says it requires libebml-devel, when there is no libebml-devel
package. The libeblm package satisfies this dependency.

Version-Release number of selected component (if applicable):
libmatroska: 0.7.5-1
libebml: 0.7.3-1


Steps to Reproduce:
1. Don't have libebml installed
2. `rpm -Uvh libmatroska-0.7.5-1.i386.rpm`
  
Actual results:
error: Failed dependencies:
        libebml-devel >= 0.7.3 is needed by libmatroska-0.7.5-1.i386

Expected results:
libmatroska says it needs libebml.

Additional info:
Requires:       libebml-devel >= 0.7.3
Should probably be:
Requires:       libebml >= 0.7.3

Comment 1 Dams 2005-03-02 15:37:30 UTC
It's not a bug. It's been designed that way. The libebml packages literaly
provides libebml-devel. AFAIK, all extras 'static only' libraries packages are
designed that way.... Dunno if we have a new guideline for that now, but it's
definitly not a bug.


Note You need to log in before you can comment on or make changes to this bug.