Bug 150068 - (IT_67609) gdb segfaults when trying to debug kernel crash dumps
gdb segfaults when trying to debug kernel crash dumps
Status: CLOSED DUPLICATE of bug 145309
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 21:57 EST by Nick Dokos
Modified: 2015-01-07 19:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 15:36:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Dokos 2005-03-01 21:57:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When we try to start up gdb to debug a kernel dump, gdb seg faults.


Version-Release number of selected component (if applicable):
gdb-6.1post-1.20040607.62

How reproducible:
Sometimes

Steps to Reproduce:
1. Produce a kernel crash dump - simplest is to enable disk dumps, enable sysrq and then "echo c > /proc/sysrq-trigger".
2. On reboot, save the dump with /etc/init.d/diskdump start (make sure there is lots of space in /var/crash).
3. Try to debug it: gdb vmlinux vmcore
  

Actual Results:  root@penryn:/var/crash/127.0.0.1-2005-02-26-09:53# gdb vmlinux vmcore
GNU gdb Red Hat Linux (6.1post-1.20040607.62rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "ia64-redhat-linux-gnu"...Using host libthread_db library "/lib/tls/libthread_db.so.1".

Core was generated by `'.
Segmentation fault (core dumped)
root@penryn:/var/crash/127.0.0.1-2005-02-26-09:53#

Expected Results:  No segfault.

Additional info:

The platform is a 4-cpu ia64 machine with 8gb of memory. The vmcore file that
is produced by savecore is a little smaller than 8gb in actual disk usage (although ls reports a size of 270Gb - it's a sparse file), but savecore
needs some extra space during the save - in my case, 12Gb has been more than
enough, but YMMV.
Comment 1 Jeff Johnston 2005-03-04 16:38:49 EST
This appears to be duplicate of 145309 which was fixed with gdb-6.3.0.0-0.10 
Gdb on RHEL-3 has switched over to use the gdb-6.3 base.  Please retry with the
newer gdb and verify.
Comment 2 Nick Dokos 2005-03-28 15:25:51 EST
[Apologies for the delay] The gdb 6.3 package does indeed fix the segfault on RHEL4.
Comment 3 Jeff Johnston 2005-03-28 15:36:32 EST
Thanks for the confirmation.  I am closing this bug as a duplicate of 145309.

*** This bug has been marked as a duplicate of 145309 ***

Note You need to log in before you can comment on or make changes to this bug.