Bug 1500723 - dhclient-script still implicitly depends on initscripts
Summary: dhclient-script still implicitly depends on initscripts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2017-10-11 11:38 UTC by Richard W.M. Jones
Modified: 2017-10-11 12:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-11 12:06:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2017-10-11 11:38:26 UTC
Description of problem:

dhcp used to depend on initscripts, but that was removed in
bug 1098172.

We build a minimal Fedora-based appliance.  We run ‘dhclient eth0’
to bring up the network interface.  This has recently broken:

+ dhclient --version
+ dhclient eth0
/usr/sbin/dhclient-script: line 813: cd: /etc/sysconfig/network-scripts: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
[    1.136759] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x256412811b4, max_idle_ns: 440795306987 ns
/usr/sbin/dhclient-script: line 813: cd: /etc/sysconfig/network-scripts: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory


initscripts used to be pulled in as a dependency of something else,
but now initscripts is no longer pulled in, and that appears to break
dhclient.

Looking at dhclient-script, it still has plenty of dependencies on
/etc/sysconfig/network-scripts from initscripts.

Version-Release number of selected component (if applicable):

dhcp-client-4.3.5-9.fc26.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Build a minimal Fedora appliance, including dhcp-client but not initscripts.
2. Run dhclient eth0.

Comment 1 Richard W.M. Jones 2017-10-11 12:06:03 UTC
So I originally thought that these messages were the problem
causing dhcp to fail.  However it turns out that the real problem
was libvirt not properly setting up the network (even dhcpcd could
not bring up the network).  I fixed this by upgrading libvirt ...


Note You need to log in before you can comment on or make changes to this bug.