Bug 150075 - unexpanding panel changes applet order in next session.
Summary: unexpanding panel changes applet order in next session.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 05:27 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-04-08 07:36:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 173029 None None None Never

Description Jens Petersen 2005-03-02 05:27:27 UTC
Description of problem:
When one unexpands the default gnome-panel,
the order of the applets changes to a apparently
"random" arbitrary order

How reproducible:
every time

Steps to Reproduce:
1. Start a gnome session for a new user.
2. Unexpand the Panel.
3. Exit and start a new gnome session.
  
Actual results:
Applets are in a completely different order than the original.

Expected results:
The order of the applets to be maintained.

Additional info:
Guessing, but it looks like after unexpanding, the applets get
re-ordered on a first-come-first-served basis.
It is pretty annoying to have to reorder the applets oneself
by hand.

I believe the behaviour probably started with fc3.

Comment 1 Mark McLoughlin 2005-04-07 12:01:45 UTC
This still happening with recent rawhide - i.e. gnome-panel-2.10.1 ?

Comment 2 Jens Petersen 2005-04-08 01:06:36 UTC
Yes.

Comment 3 Mark McLoughlin 2005-04-08 07:36:24 UTC
Thanks, moved upstream:

  http://bugzilla.gnome.org/show_bug.cgi?id=173029


Note You need to log in before you can comment on or make changes to this bug.