Bug 150079 - clustat -i 5 segfaults after about 25-30 seconds of running
clustat -i 5 segfaults after about 25-30 seconds of running
Status: CLOSED UPSTREAM
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: magma-plugins (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 03:51 EST by Lon Hohberger
Modified: 2009-04-16 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 12:08:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2005-03-02 03:51:08 EST
Description of problem:

SSIA

Version-Release number of selected component (if applicable): Current CVS


How reproducible: 100%


Steps to Reproduce:
1.  Start clurgmgrd with several configured resource groups
2.  Run clustat -i 5

  
Actual results:Member Status: Quorate, Group Member

  Member Name                              State      ID
  ------ ----                              -----      --
  cyan                                     Online     0x0000000000000004
  blue                                     Online     0x0000000000000003
  red                                      Online     0x0000000000000001

  Resource Group       Owner (Last)                   State
  -------- -----       ----- ------                   -----
  nfsservice           red                            started
  redonly              red                            started
  greenonly            (none                        ) stopped
  nostart              blue                           started
  exclusive            cyan                           started
  greenpref            red                            started
Segmentation fault



Expected results:
No segfault

Additional info:
It also looks like rgmanager doesn't process other events if it processes a
network event.  For instance, status checks seem to be delayed.
Comment 1 Lon Hohberger 2005-03-02 12:08:49 EST
The segfault was a SM plugin problem.  We weren't zeroing out the
cm_addrs field when reading from /proc/cluster/services.

The processing-event part was just incorrect logic in main.c of rgmanager.

Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.