Bug 1500834 - VirtualBox: black screen on fedora 27
Summary: VirtualBox: black screen on fedora 27
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1506056 (view as bug list)
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-11 14:58 UTC by Quentin Tayssier
Modified: 2017-11-14 01:53 UTC (History)
35 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-24 08:08:58 UTC


Attachments (Terms of Use)

Description Quentin Tayssier 2017-10-11 14:58:13 UTC
Description of problem:

Doing upgrade from fedora 26 workstation to fedora 27 on virtualbox
After the upgrade i got a black screen after the os start. Console are accessible and useable.


Additional info:
I have the same issue if i launch a workstation fedora 27 live image on virtualbox. The work around is to start the live image with basic graphic mode, do the installation and after the reboot the install work find without black screen.

Comment 1 Quentin Tayssier 2017-10-11 15:00:48 UTC
Same issue from fedora 25 workstation to fedora 27

Comment 2 Jeremy Bicha 2017-10-15 17:34:55 UTC
I can reproduce this issue with today's Fedora-27-20171015.n.0 Workstation Live compose

https://fedoraproject.org/wiki/Changes/VirtualBox_Guest_Integration

Ubuntu disabled the new upstreamed VirtualBox drivers in the Linux 4.13 kernel for Ubuntu 17.10 because of a similar issue.

CONFIG_DRM_VBOXVIDEO=n https://launchpad.net/bugs/1718679

Comment 3 Fedora Blocker Bugs Application 2017-10-15 17:36:40 UTC
Proposed as a Blocker for 27-final by Fedora user jbicha using the blocker tracking app because:

 This is a regression from Fedora 26 and VirtualBox is a popular way to use Fedora desktop.

https://fedoraproject.org/wiki/Changes/VirtualBox_Guest_Integration

Contingency mechanism: The proposal owner will remove the VirtualBox Guest Additions package from the default package list for the Workstation product if it is not working properly
Contingency deadline: Beta Freeze

Comment 4 Hans de Goede 2017-10-15 19:32:33 UTC
This is fixed by this Fedora kernel commit:

http://pkgs.fedoraproject.org/cgit/rpms/kernel.git/commit/?h=f27&id=1a4bd40a9207ac83009e8f827cb08c84c3d2aa09

We are just waiting for the kernel team to kick of a new build, once that is done this is resolved.

Comment 5 Gianfranco 2017-10-16 06:37:07 UTC
I can confirm the fix in Ubuntu (cherry-picked from your patch)

Comment 6 Peter Robinson 2017-10-17 09:52:04 UTC
Should be fixed in the 4.13.7-300 kernel
https://koji.fedoraproject.org/koji/buildinfo?buildID=985044

Comment 7 Fedora Update System 2017-10-23 17:05:42 UTC
kernel-4.13.8-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa9927961f

Comment 8 Geoffrey Marr 2017-10-23 21:22:39 UTC
Discussed during the 2017-10-23 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker and an AcceptedFreezeException was made as vbox isn't one of the officially-blocking virt technologies and a workaround is available. This is widely used however, and so warrants a FreezeException.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-23/f27-blocker-review.2017-10-23-16.00.txt

Comment 9 Fedora Update System 2017-10-24 05:29:43 UTC
kernel-4.13.8-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Kamil Páral 2017-10-24 08:08:58 UTC
Pushed to stable, closing.

Comment 11 Jeremy Bicha 2017-10-27 02:29:12 UTC
Today's workstation live Fedora-27-20171026.n.0 compose works great. Thanks!

Comment 12 Alessio 2017-10-30 04:59:52 UTC
*** Bug 1506056 has been marked as a duplicate of this bug. ***

Comment 13 Adam Williamson 2017-11-14 01:53:09 UTC
so no longer needs CommonBugs.


Note You need to log in before you can comment on or make changes to this bug.