Bug 150088 - Non printable characters cause fetchmail syntax errors
Summary: Non printable characters cause fetchmail syntax errors
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: fetchmail   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 14:21 UTC by Tethys
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 17:10:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tethys 2005-03-02 14:21:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
Some spam arrives at my mail server with unprintable characters in the "from" address. When fetchmail attempts to download it to my local machine using POP3,
it gives the error:

fetchmail: SMTP error: 501 5.1.7 Syntax error in mailbox address "t[???o^?t@sendmail.a.ha" (non-printable character)

Later versions of fetchmail (e.g. fetchmail-6.2.5-2 as found in FC2) fix this
problem. However, the latest version available for RHEL3 is only 6.2.0-3. This
is causing my mailbox to fill up with large numebrs of errors from cron as
fetchmail complains about the malformed messages each time it's run.

Version-Release number of selected component (if applicable):
fetchmail-6.2.0-3

How reproducible:
Always

Steps to Reproduce:
1. Send a message with a non printable character in the from address to yourself
2. Attempt to download it using fetchmail
3.
  

Additional info:

Comment 1 Miloslav Trmač 2005-06-07 17:10:01 UTC
I'm sorry for the late response.

Fetchmail <=6.2.3 is keeping the messages in the source mailbox
if the bounce is sent to the postmaster; it is safer than deleting
the e-mail because the bounce doesn't contain the body of the
e-mail; if the e-mail were legitimate, it would be lost.

I think that changing this behavior within a RHEL series would be breaking
the stability promise of RHEL.

You can configure fetchmail to just delete e-mails when it recieves a 501
response from the SMTP server (>instead of keeping them in the mailbox and
sending a bounce) by adding 501 to the "antispam" variable in your
.fetchmailrc.


Note You need to log in before you can comment on or make changes to this bug.