Bug 1500946 - Heapster failing to start because secret heapster-certs not found secret after upgrade to 3.6 from 3.5
Summary: Heapster failing to start because secret heapster-certs not found secret afte...
Status: CLOSED DUPLICATE of bug 1500981
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Juraci Paixão Kröhling
QA Contact: Junqi Zhao
URL:
Whiteboard:
Keywords: Unconfirmed
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-11 19:50 UTC by Eric Jones
Modified: 2017-10-13 08:45 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-13 08:45:07 UTC


Attachments (Terms of Use)

Description Eric Jones 2017-10-11 19:50:19 UTC
Description of problem:
After upgrading the cluster to 3.6, customer ran the metrics playbook and now heapster fails to start with this event error [0] but that is because this secret doesn't exist at all in their cluster [1].

[0]
MountVolume.SetUp failed for volume "ku
bernetes.io/secret/0e2d2737-acb1-11e7-aa82-001a4a48be58-heapster-certs" (spec.Name: "heapster-certs") pod "0e2d2737-acb1-11e7-aa82-001a4a48be58" (UID: "0e2d2737-acb1-11e7-aa82-001a4a48be58") with: secrets "heapster-certs" not found

[1]
[root@ose-prod-master-01 playbook-openshift]# oc get secrets | grep heapster
heapster-dockercfg-cje04                                  kubernetes.io/dockercfg               1         203d
heapster-secrets                                          Opaque                                4         203d
heapster-token-ld2ap                                      kubernetes.io/service-account-token   3         203d
heapster-token-pijgm                                      kubernetes.io/service-account-token   3         203d

Version-Release number of selected component (if applicable):
ansible-2.3.2.0-2.el7.noarch
openshift-ansible-3.6.173.0.21-2.git.0.44a4038.el7.noarch
openshift-ansible-playbooks-3.6.173.0.21-2.git.0.44a4038.el7.noarch

Additional info:
Attaching ansible playbook output and inventory file shortly.

Comment 2 Juraci Paixão Kröhling 2017-10-13 08:45:07 UTC
Eric, this look a lot like BZ 1500981 . I'm closing this, marking as duplicate of that. If the solution presented there does not solve the issue you reported, feel free to reopen this.

*** This bug has been marked as a duplicate of bug 1500981 ***


Note You need to log in before you can comment on or make changes to this bug.