Bug 150109 - Can't disable anti-aliasing in firefox 1.0.1
Summary: Can't disable anti-aliasing in firefox 1.0.1
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 15:56 UTC by Stian Husemoen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 16:36:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stian Husemoen 2005-03-02 15:56:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After an update, firefox no longer respects GDK_USE_XFT=0 and uses
anti-aliased fonts anyway

Version-Release number of selected component (if applicable):
firefox-1.0.1-1.3.1

How reproducible:
Always

Steps to Reproduce:
1. GDK_USE_XFT=0 firefox 
2.
3.
    

Additional info:

Comment 1 Steve Adams 2005-03-24 16:11:06 UTC
I can confirm that this bug is specific to the Fedora build and persists in the
most recent update (firefox-1.0.2-1.3.1). The latest installer build from
mozilla.org (Firefox 1.0.2 for Linux i686, English) does not have this bug and
continues to respect GDK_USE_XFT=0 to disable anti-aliased fonts.

Comment 2 Christopher Blizzard 2005-03-24 16:34:34 UTC
I wonder if you can use MOZ_DISABLE_PANGO=1 GDK_USE_XFT=0 to fall all the way
back to core fonts.

Comment 3 Christopher Blizzard 2005-03-24 16:36:13 UTC
Actually, I should wontfix this because eventually we're going to remove bitmap
font support in the form of core x fonts.  (Disabling anti-aliasing via render
and pango is still an option, though.)

Comment 4 Havoc Pennington 2005-03-24 16:44:43 UTC
This is not a bug. GDK_USE_XFT is not the right way to disable AA, it's a way to
enable the deprecated old font system which happens to not support AA. But the
new font system has a no-AA mode.

To disable AA, change the font configuration. Preferences->Fonts, or
/etc/fonts/fonts.conf


Note You need to log in before you can comment on or make changes to this bug.