Bug 150117 - zero division error in partitioning
Summary: zero division error in partitioning
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 17:04 UTC by Giampiero Campa
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 21:09:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (41.94 KB, text/plain)
2005-03-02 17:04 UTC, Giampiero Campa
no flags Details

Description Giampiero Campa 2005-03-02 17:04:41 UTC
... when there are two hard disks and 
only one is selected to remove partitions.

It does not happen if you select both of them.

Comment 1 Giampiero Campa 2005-03-02 17:04:43 UTC
Created attachment 111583 [details]
anaconda dump

Comment 2 Chris Lumens 2005-03-11 15:35:07 UTC
Which steps are you taking in the partitioning section?  Are you doing
autopartitioning or manual?  Do you make any changes to the partition layout
that cause this exception?

Comment 3 Giampiero Campa 2005-03-11 19:09:19 UTC
I was doing autopartitioning. No change to the partition Layout.
One hard disk is 60 gb the other instead is an 8MB flashcard
mounted on the IDE. When i exclude the latter and i select 
"remove all partitions" o "remove all linux partition" 
i get the error. 

If i do not exclude the flashcard then i go through.


Comment 4 Jeremy Katz 2005-03-14 17:14:46 UTC
What are hdb and hdc?  They're showing very odd geometries from the kernel probe...

Comment 5 Giampiero Campa 2005-03-17 19:07:22 UTC
hda is the 60GB drive (master 1)
hdb is a zip drive (slave 1)

hdc is the 8MB flashcard (master 2)
hdd is the cdrom (slave 2)

to install the system i had to remove the 
flashcard and mount the cdrom as master


Comment 6 Chris Lumens 2005-05-12 17:10:15 UTC
New idea:  before getting to the partition screen but after the GUI portion of
the installer has started, can you press ctrl-alt-f2 to bring up a terminal
window, and then type parted /dev/hdc?  That will bring you into parted.  Then
type "p" to print the partition table and "q" to quit.  What information is
parted giving you for this device?  Specifically, what's the geometry and the
partition table?

Please run this under the exact setup as you are experiencing the errors.  That
is, if you have a card in it, leave the card in.  If you don't, don't put one in.

Comment 7 Jeremy Katz 2005-09-21 21:09:02 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.