Bug 150119 - rhnsd sets SIGPIPE to Ignore (SIG_IGN) causing problems with commands (Remote Commands) executed via rhnsd
rhnsd sets SIGPIPE to Ignore (SIG_IGN) causing problems with commands (Remote...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Red Hat Satellite QA List
:
Depends On:
Blocks: 146166
  Show dependency treegraph
 
Reported: 2005-03-02 12:06 EST by Mustafa Mahudhawala
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:06:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mustafa Mahudhawala 2005-03-02 12:06:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The SIGPIPE signal is set to be ignored in rhnsd.c via syscall:
signal (SIGPIPE, SIG_IGN);

Due to this, actions (commands) scheduled to be executed via RHN, when
executed using rhn_check, also inheret an ignored SIGPIPE

This causes problems with certain utilities like cron, which when
restarted, pass this Ignored SIGPIPE further down causing problems like:

zcat: stdout: Broken pipe
(while running makewhatis.cron)

Refer Bugzilla #64836

Possibly also impacts up2date-4.2.57-2 from RHEL 3 Update 4.

Version-Release number of selected component (if applicable):
up2date-4.2.38-1

How reproducible:
Always

Steps to Reproduce:
Run the following via Remote Command -> Script Window

#!/bin/sh
exec 1>/tmp/test
echo "Sending SIGPIPE to Self (Pid $$)"
kill -s SIGPIPE $$
echo "SIGPIPE Ignored"


Actual Results:  (Executed via rhnsd)

# cat /tmp/test
Sending SIGPIPE to Self (Pid 7069)
SIGPIPE Ignored

Expected Results:  (Running Directly via Shell)

#./test.sh
Sending SIGPIPE to Self (Pid 7115)
Broken pipe


Additional info:
Comment 2 Adrian Likins 2005-03-02 12:28:58 EST
Off hand, I'm not sure why it's ignoring SIGPIPE. I inherited
that code, so I'm bug the original author what the intent
was. 
Comment 3 Shawn Michael 2005-03-08 11:07:45 EST
Adrian,

I origionally reported this bug via Red Hat Support ticket 487796. I
was just wondering if there was a time schedule for a fix with this?

Shawn
Comment 4 Jason Connor 2006-01-17 00:54:05 EST
We really should look into the use cases for this bug.
Comment 5 Fanny Augustin 2006-03-16 15:08:27 EST
Moving to the triage list
Comment 6 Fanny Augustin 2006-03-16 15:15:53 EST
Disassociating from top-level tracking bug
Comment 7 RHEL Product and Program Management 2007-10-19 15:06:43 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.