Bug 150132 - gnome-vfs 2.9.9x uses neon 0.24 which does not support gssapi correctly
Summary: gnome-vfs 2.9.9x uses neon 0.24 which does not support gssapi correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-02 20:12 UTC by Sean Middleditch
Modified: 2013-03-06 03:42 UTC (History)
1 user (show)

Fixed In Version: 2.10.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 00:46:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update gvs neon library to use neon 0.25 gssapi support; patch from fedora originally (17.53 KB, patch)
2005-03-02 20:14 UTC, Sean Middleditch
no flags Details | Diff

Description Sean Middleditch 2005-03-02 20:12:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050227 Firefox/1.0.1 Fedora/1.0.1-2

Description of problem:
Gnome-vfs 2.9.x uses Neon 0.24.  However, neon 0.24 does not properly support GSSAPI.  In fact, Fedora already ships a patch with its Neon 0.24 that applies the GSSAPI code from the Neon 0.25 development series in order to get proper GSSAPI support.  However, since gnome-vfs includes its own copy of Neon and does not use the system Neon, this patch does not help gnome-vfs.

I have ported the patch including in Fedora's neon package (http://cvs.fedora.redhat.com/viewcvs/devel/neon/neon-0.24.7-gssapi.patch) to gnome-vfs 2.9.91.  This patch when applied allows me to connect to WebDAV shares using GSSAPI in Nautilus and other gnome-vfs-using apps.

I have already filed this upstream with GNOME, but I think they are more likely to just wait to upgrade wholesale to Neon 0.25.  Since Fedora cares more about GSSAPI/Kerberos than GNOME, I thought you guys might be interested in applying it for FC4.

Version-Release number of selected component (if applicable):
gnome-vfs2-2.9.91-2

How reproducible:
Always

Steps to Reproduce:
1. try to connect to a webdav share using GSSAPI with a gnome-vfs-using app
2. won't work; you'll likely jsut be prompted for a password
3. apply patch, see it work beautifully
  

Additional info:

Comment 1 Sean Middleditch 2005-03-02 20:14:02 UTC
Created attachment 111590 [details]
update gvs neon library to use neon 0.25 gssapi support; patch from fedora originally

Comment 2 Sean Middleditch 2005-03-02 20:14:48 UTC
changed component to gnome-vfs2 - sorry about that.

Comment 3 Jeremy Katz 2005-04-28 01:05:44 UTC
We really should be linking to the system libneon anyway -- otherwise, we have
something else which may need updates at various points.

Comment 4 David Zeuthen 2005-05-03 15:40:16 UTC
OK, gnome-vfs2-2.10.0-5 should appear in Rawhide tomorrow. Thanks for the
patches. Please let me know if the package works as intended.

Comment 5 Sean Middleditch 2005-05-10 00:37:03 UTC
Yes, it works perfectly for me now.  Thank you.

Comment 6 David Zeuthen 2005-05-10 00:46:58 UTC
Thanks for the testing. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.