Bug 1501355 - No symlink for objcopy in libexec
Summary: No symlink for objcopy in libexec
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gcc
Version: DTS 6.0 RHEL 7
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: alpha
: 7.0
Assignee: Marek Polacek
QA Contact: Michael Petlan
Vladimír Slávik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-12 12:28 UTC by Piyush Bhoot
Modified: 2018-05-03 05:14 UTC (History)
10 users (show)

Fixed In Version: devtoolset-7-gcc-7.2.1-6.1.el7
Doc Type: Bug Fix
Doc Text:
Previously, the "devtoolset-7-gcc" package did not contain a symbolic link to the *objcopy* utility installed by the "devtoolset-7-binutils" package. As a consequence, *GCC* from Red Hat Developer Toolset used the system version of *objcopy* which lacked some features, such as the `-gsplit-dwarf` option. The symbolic link has been added and the correct version of *objcopy* is now used.
Clone Of:
Environment:
Last Closed: 2018-05-03 05:13:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1293 None None None 2018-05-03 05:14:38 UTC

Description Piyush Bhoot 2017-10-12 12:28:12 UTC
Description of problem:
Need a link to objcopy to better support split dwarf
The RH Developer Toolset is missing a symbolic link necessary for seamless use of the relatively new Split Dwarf (or DebugFission) feature.


In particular, there should be an objcopy symbolic link in:
/opt/rh/devtoolset-6/root/usr/libexec/gcc/x86_64-redhat-linux/6.2.1

Pointing to:
../../../../bin/objcopy

If you look in /opt/rh/devtoolset-6/root/usr/libexec/gcc/x86_64-redhat-linux/6.2.1, you will see symbolic links for other compiler-needed binutils tools such as ar, as, ld, nm, ranlib, strip.  For –gsplit-dwarf to work, the compiler also needs the matching version of objcopy.


Version-Release number of selected component (if applicable):
devtoolset-6-binutils-2.27-12.el7.1.x86_64

How reproducible:
Always

Steps to Reproduce:

ls -l devtoolset-6/root/usr/libexec/gcc/x86_64-redhat-linux/6.2.1 | grep bin
 	ar -> lrwxrwxrwx 1 root root       18 Apr 27 15:26 ar -> ../../../../bin/ar
	as ->lrwxrwxrwx 1 root root       18 Apr 27 15:26 as -> ../../../../bin/as
	ld ->lrwxrwxrwx 1 root root       18 Apr 27 15:26 ld -> ../../../../bin/ld
	ld.bdf->lrwxrwxrwx 1 root root       22 Apr 27 15:26 ld.bfd -> ../../../../bin/ld.bfd
	ld.gold->lrwxrwxrwx 1 root root       23 Apr 27 15:26 ld.gold -> ../../../../bin/ld.gold
	nm->lrwxrwxrwx 1 root root       18 Apr 27 15:26 nm -> ../../../../bin/nm

link for objcopy is missing

Additional info:

Comment 4 Nick Clifton 2018-01-09 16:33:53 UTC
Reassigning to gcc, as the symlinks are actually constructed by the %install phase of the gcc.spec file.

Comment 5 Marek Polacek 2018-01-09 19:29:56 UTC
Fixed in git.

Comment 8 Michael Petlan 2018-04-26 22:31:37 UTC
Tested with devtoolset-7-gcc-7.3.1-5.4. It has the requested symlink.
VERIFIED.

Comment 11 errata-xmlrpc 2018-05-03 05:13:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1293


Note You need to log in before you can comment on or make changes to this bug.