Bug 150140 - firefox does not BuildRequires gnome-libs-devel
firefox does not BuildRequires gnome-libs-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 15:53 EST by Mihai Ibanescu
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 16:42:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mihai Ibanescu 2005-03-02 15:53:23 EST
Granted, it's not that common to have most other -devel rpms but not
gnome-libs-devel

It was complaining that it couldn't find libgnome.h
Comment 1 Mihai Ibanescu 2005-03-02 17:39:23 EST
Looks like libgnome-devel and libgnomeui-devel will do the trick.

Now, that didn't solve my problem, firefox segfaults when I try to use the
calendar. Maybe something to do with 64-bit

RFE in general: can we/should we enable the calendar in our builds by default?
If so, do you need another bug?

(to enable it, just add ac_add_options --enable-calendar in
$SOURCES/mozconfig-firefox - no need to patch anything )
Comment 2 Christopher Aillon 2005-03-02 18:10:41 EST
Firefox is a lightweight browser only client.  Shipping anything else in it
defeats the whole idea of firefox.  I am working on getting the mozilla calendar
built standalone, but for now, use evolution.  I'll add the BR tonight with some
other changes for gcc4, and a few patch updates.  Look for a fix tomorrow.
Comment 3 Marius Andreiana 2005-08-20 03:29:00 EDT
Salut Mihai, does this work for you now?
Comment 4 Christopher Aillon 2006-10-29 16:42:42 EST
% grep libgnome firefox.spec
firefox.spec:90:BuildRequires:  libgnome-devel
firefox.spec:91:BuildRequires:  libgnomeui-devel

Note You need to log in before you can comment on or make changes to this bug.