Bug 150166 - oowriter seg fault when use with IIIMF
Summary: oowriter seg fault when use with IIIMF
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
high
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 137160
TreeView+ depends on / blocked
 
Reported: 2005-03-03 06:40 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
4 users (show)

Fixed In Version: 1.1.2-24.6.0.EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-05 08:19:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2005-03-03 06:40:03 UTC
Description of problem:
oowriter keep experiencing seg fault when used with im-sdk.

Tried to reproduce in en_US locale but the error did not surfaced.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-20.6.EL4 in dist-U1
im-sdk-12.1-12.EL in dist-U1-HEAD

How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_TW.UTF-8 oowriter
2.CTRL-SPACE to activate LE
3.enter 'a' 4 times
4.right mouse click on anywhere in the text area of oowriter till oowriter seg
fault  (took me 4 clicks)

Actual results:
Seg fault

Expected results:
No seg fault

Additional info:
I tried Dan's recent libvclplug_gtk645li.so patch and it is able to stop the seg
fault from occuring.

Comment 1 Lawrence Lim 2005-03-03 06:41:45 UTC
Additional Test Case
1. LANG=ja_JP.UTF-8 oowriter
2. CTRL-SPACE to activate LE
3. enter 'a' 4 times
4. right mouse click on anywhere in the text area of oowriter till oowriter seg
fault  (took me 4 clicks)



Comment 2 Dan Williams 2005-03-03 12:35:13 UTC
llim: openoffice.org-1.1.2-21.6.EL4 in dist-4E-U1-HEAD should correct this crash.

Comment 3 Leon Ho 2005-03-03 22:53:19 UTC
llim: good QA'ing in U1

New im-sdk in -HEAD need to be pushed *along* with OOo to get this fix as well.
We cannot risk to have a crashing system.

Comment 4 Dan Williams 2005-03-04 06:35:49 UTC
->modified since current builds (-21 and -22) have this fix.  It involves
protecting calls to gtk_im_context_reset() so that while inside the
gtk_im_context_reset() we don't allow recursion, similar to the "need_im_reset"
stuff in GTK+.  Segfault was actually a stack overflow due to this recursion.

Comment 5 Lawrence Lim 2005-04-06 04:28:06 UTC
Tested with openoffice.org-1.1.2-22.6.EL4 against CJKI locale, confirmed this
has been fixed.

Comment 6 Caolan McNamara 2005-05-04 16:31:05 UTC
did this one get shipped ?

Comment 7 Lawrence Lim 2005-05-05 06:03:53 UTC
Took the chance to test with openoffice.org-1.1.2-24.6.0.EL4, cant reproduce the
bug anymore.


Note You need to log in before you can comment on or make changes to this bug.