Bug 1501761 - Add the additional host to the HostedEngine failed due to miss the package "qemu-kvm-tools"
Summary: Add the additional host to the HostedEngine failed due to miss the package "q...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM
Version: 1.6.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: ovirt-4.1.7
: 1.6.7
Assignee: Sandro Bonazzola
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks: 1503505
TreeView+ depends on / blocked
 
Reported: 2017-10-13 07:10 UTC by Yihui Zhao
Modified: 2019-06-18 09:29 UTC (History)
20 users (show)

Fixed In Version: ovirt-host-deploy-1.6.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 12:29:28 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
rule-engine: ovirt-4.2+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
qemu-kvm-tools package not found. img (26.28 KB, image/png)
2017-10-13 07:12 UTC, Yihui Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1426580 'unspecified' 'CLOSED' 'Remove qemu-kvm-tools installation' 2019-12-03 23:33:48 UTC
Red Hat Bugzilla 1426581 'unspecified' 'CLOSED' 'Remove qemu-kvm-tools dependency' 2019-12-03 23:33:48 UTC
Red Hat Knowledge Base (Solution) 4046231 Troubleshoot None When you append the RHVH4.2 host to the RHV4.1 Manager, an error message “Failed to install Host {HostName}. Yum Cannot ... 2019-06-18 09:25:44 UTC
oVirt gerrit 82838 'None' 'MERGED' 'packaging: make qemu-kvm-tools optional' 2019-12-03 23:33:51 UTC

Internal Links: 1426580 1426581

Description Yihui Zhao 2017-10-13 07:10:56 UTC
Description of problem:
Missing the "qemu-kvm-tools" package resulting in failing to add additional host to HostedEngine.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.2-20171011.2
cockpit-ovirt-dashboard-0.11.0-0.0.3.el7ev.noarch
qemu-img-rhev-2.9.0-16.el7_4.5.x86_64
qemu-kvm-common-rhev-2.9.0-16.el7_4.5.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.5.x86_64
libvirt-daemon-driver-qemu-3.2.0-14.el7_4.3.x86_64
ipxe-roms-qemu-20170123-1.git4e85b27.el7_4.1.noarch
qemu-guest-agent-2.8.0-2.el7.x86_64
rhvm-appliance-4.1.20170927.0-1.el7.noarch
ovirt-hosted-engine-setup-2.2.0-0.1.master.git21639e3.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. Clean install redhat-virtualization-host-4.2-20171011.2
2. Login to cockpit webUI with root account
3. Deploy HostedEngine
4. Add additional host via engine
5. Check the HE status

Actual results:
After step 4, add additional host failed, from the engine event, it shows that 
"Failed to install Host yzhao. Yum Cannot queue package qemu-kvm-tools: Package qemu-kvm-tools cannot be found."


Expected results:
After step 4, add additional host successfully.


Additional info:

Comment 1 Yihui Zhao 2017-10-13 07:12:45 UTC
Created attachment 1338107 [details]
qemu-kvm-tools package not found. img

Comment 2 Yihui Zhao 2017-10-13 08:26:20 UTC
(In reply to Yihui Zhao from comment #0)
> Description of problem:
> Missing the "qemu-kvm-tools" package resulting in failing to add additional
> host to HostedEngine.
> 
> 
> Version-Release number of selected component (if applicable):
> redhat-virtualization-host-4.2-20171011.2
> cockpit-ovirt-dashboard-0.11.0-0.0.3.el7ev.noarch
> qemu-img-rhev-2.9.0-16.el7_4.5.x86_64
> qemu-kvm-common-rhev-2.9.0-16.el7_4.5.x86_64
> qemu-kvm-rhev-2.9.0-16.el7_4.5.x86_64
> libvirt-daemon-driver-qemu-3.2.0-14.el7_4.3.x86_64
> ipxe-roms-qemu-20170123-1.git4e85b27.el7_4.1.noarch
> qemu-guest-agent-2.8.0-2.el7.x86_64
> rhvm-appliance-4.1.20170927.0-1.el7.noarch
> ovirt-hosted-engine-setup-2.2.0-0.1.master.git21639e3.el7ev.noarch
> 
> How reproducible:
> 100%
> 
> 
> Steps to Reproduce:
> 1. Clean install redhat-virtualization-host-4.2-20171011.2
> 2. Login to cockpit webUI with root account
> 3. Deploy HostedEngine
> 4. Add additional host via engine
> 5. Check the HE status
> 
> Actual results:
> After step 4, add additional host failed, from the engine event, it shows
> that 
> "Failed to install Host yzhao. Yum Cannot queue package qemu-kvm-tools:
> Package qemu-kvm-tools cannot be found."
> 
> 
> Expected results:
> After step 4, add additional host successfully.
> 
> 
> Additional info:

 Also failed to register RHVH 4.2 to engine due to miss  "qemu-kvm-tools"  package.

Comment 3 Red Hat Bugzilla Rules Engine 2017-10-13 12:02:26 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 4 Sandro Bonazzola 2017-10-16 13:37:53 UTC
Need to investigate on this because qemu-kvm-tools shouldn't be required since it doesn't exist anymore.

Comment 5 Sandro Bonazzola 2017-10-16 14:07:40 UTC
qemu-kvm-tools requirement has been dropped 8 months ago from ovirt-host-deploy.
Can you please attach log-collector report including hypervisor report?

Comment 6 Sandro Bonazzola 2017-10-16 14:10:15 UTC
Oh, I see, you're using rhvm-appliance 4.1 on a 4.2 RHV-H.
Is this a supported case?

Comment 7 Sandro Bonazzola 2017-10-16 14:41:01 UTC
Removing TestBlocker since you can still test oVirt Node 4.2 with a 4.2 engine instead of a 4.1 appliance.

Comment 10 Pavol Brilla 2017-11-02 13:32:37 UTC
Tested against u/s builds: engine 4.1-pre / host 4.2-pre

engine# yum list ovirt-engine ovirt-host-deploy                                    
Installed Packages
ovirt-engine.noarch                           4.1.7.5-1.el7.centos                       @ovirt-4.1-pre
ovirt-host-deploy.noarch                      1.6.7-1.el7.centos                         @ovirt-4.1-pre

host# yum list ovirt-host-deploy vdsm
Available Packages
ovirt-host-deploy.noarch      1.7.0-0.0.master.20171012082735.git24e53fd.el7.centos       ovirt-4.2-pre
vdsm.x86_64                   4.20.5-1.el7.centos                                         ovirt-4.2-pre

Problem is that qemu-kvm-tools-ev-10:2.9.0-16.el7_4.8.1.x86_64 is still isntalled from @centos-qemu-ev-release

Comment 11 Sandro Bonazzola 2017-11-02 13:39:25 UTC
If the pkg is available it gets installed. The fix is that if the package is missing it doesn't fail.
You can force it missing by setting exclude=qemu-kvm-tools-ev in yum repo conf

Comment 12 Pavol Brilla 2017-11-02 13:46:44 UTC
Setup same as in comment10
+
# grep exclude /etc/yum.conf 
exclude=qemu-kvm-tools-ev

host 4.2-pre added to 4.1-pre engine without any issue


Note You need to log in before you can comment on or make changes to this bug.