Bug 1501763 - Requesting CentOS machine to debug regression failure for CR 18485
Summary: Requesting CentOS machine to debug regression failure for CR 18485
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-13 07:17 UTC by Anoop C S
Modified: 2017-11-07 10:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-07 08:39:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
public key (396 bytes, text/plain)
2017-10-13 07:17 UTC, Anoop C S
no flags Details

Description Anoop C S 2017-10-13 07:17:07 UTC
Created attachment 1338108 [details]
public key

Description of problem:
Change https://review.gluster.org/#/c/18485/ posted for fixing the errors in hooks scripts reported with Shellcheck utility failed to run regressions successfully on CentOS machines. Following test case failed in consecutive runs:

tests/basic/afr/split-brain-resolution.t

However it ran successfully on my local system (Fedora 26). So requesting a CentOS machine to root cause the issue.

Comment 1 Nigel Babu 2017-10-17 04:07:33 UTC
You should be able to SSH in as jenkins@slave27.cloud.gluster.org. Please delete any temporary files after you're done.

Comment 2 Nigel Babu 2017-11-03 10:07:57 UTC
Is this activity complete? I really expect loaners to be back in 1 week with 2 being maximum.

Comment 3 Anoop C S 2017-11-07 06:44:01 UTC
Actually I was trying to reproduce the issue locally on a CentOS 6 machine. I was unable to do so. https://review.gluster.org/#/c/18485/2/extras/hook-scripts/create/post/S10selinux-label-brick.sh has some background.

For now you can take back the machine.

Comment 4 Nigel Babu 2017-11-07 08:37:08 UTC
So, when I was working on https://review.gluster.org/#/c/17681/ I had a conversation with Niels about this. It works because as long as we get the context applied to the top level folder, the restorecon will make it work on the rest.

Comment 5 Nigel Babu 2017-11-07 08:39:14 UTC
Machine back in the pool.

Comment 6 Anoop C S 2017-11-07 10:37:18 UTC
(In reply to Nigel Babu from comment #4)
> So, when I was working on https://review.gluster.org/#/c/17681/ I had a
> conversation with Niels about this. It works because as long as we get the
> context applied to the top level folder,

As of now it is not even being applied to the top level directory via hook-scripts. That was my point.


Note You need to log in before you can comment on or make changes to this bug.