Bug 1501889 - Even when --rhsm.auto_enable_yum_plugins=0 is set in rhsm.conf file yum plugins are automatically enabled after you execute RHSM commands
Summary: Even when --rhsm.auto_enable_yum_plugins=0 is set in rhsm.conf file yum plugi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-13 12:25 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:52:27 UTC
Github candlepin subscription-manager pull 1714 None None None 2017-10-16 19:58:03 UTC

Description Shwetha Kallesh 2017-10-13 12:25:10 UTC
Description of problem:
Even when --rhsm.auto_enable_yum_plugins=0 is set in rhsm.conf file yum plugins are automatically enabled after you execute RHSM commands 

Version-Release number of selected component (if applicable):
[root@hp-dl160g8-1 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.2-1.el7
python-rhsm: 1.20.2-1.el7


How reproducible:


Steps to Reproduce:

Disable the subscription-manager yum plugin and verify:

[root@hp-dl160g8-1 ~]# sed -i s/enabled=./enabled=0/g /etc/yum/pluginconf.d/subscription-manager.conf

[root@hp-dl160g8-1 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=0


Turn off the auto_enable_yum_plugins=0 configuration and verify

[root@hp-dl160g8-1 ~]# subscription-manager config --rhsm.auto_enable_yum_plugins=0
WARNING

The yum plugins: /etc/yum/pluginconf.d/subscription-manager.conf were automatically enabled for the benefit of Red Hat Subscription Management. If not desired, use "subscription-manager config --rhsm.auto_enable_yum_plugins=0" to block this behavior.

[root@hp-dl160g8-1 ~]# cat /etc/rhsm/rhsm.conf | grep auto_enable_yum_plugins
auto_enable_yum_plugins = 0

Run any sub-man cmd :

[root@hp-dl160g8-1 ~]# subscription-manager clean
All local data removed

Now very if yum plugin remains disabled:

[root@hp-dl160g8-1 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=1


Actual results:
enabled=1

Expected results:
enabled=0

Additional info:

Comment 2 John Sefler 2017-10-13 17:45:37 UTC
This is ironically funny...  subscription-manager config is automatically enabling the disabled yum plugins while in the process of turning off the rhsm.auto_enable_yum_plugins configuration in rhsm.conf to prevent subscription-manager from automatically enabling the yum plugins.

Comment 3 Kevin Howell 2017-10-16 14:07:55 UTC
Let's special-case the config subcommand so that comment 2 doesn't happen.

Comment 5 Shwetha Kallesh 2017-11-07 11:01:14 UTC
Verified

[root@hp-ms-01-c02 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7


Disable the subscription-manager yum plugin and verify:

[root@hp-ms-01-c02 ~]#  sed -i s/enabled=./enabled=0/g /etc/yum/pluginconf.d/subscription-manager.conf
[root@hp-ms-01-c02 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=0

Turn off the auto_enable_yum_plugins=0 configuration and verify

[root@hp-ms-01-c02 ~]# subscription-manager config --rhsm.auto_enable_yum_plugins=0


[root@hp-ms-01-c02 ~]# cat /etc/rhsm/rhsm.conf | grep auto_enable_yum_plugins
auto_enable_yum_plugins = 0

Run sub-man command:

[root@hp-ms-01-c02 ~]# subscription-manager clean
All local data removed

Now very if yum plugin remains disabled:

[root@hp-ms-01-c02 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=0

Comment 8 errata-xmlrpc 2018-04-10 09:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.