Bug 150199 - snmpd exits without a diagnostic: SIGSEGV
Summary: snmpd exits without a diagnostic: SIGSEGV
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
: 161492 (view as bug list)
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-03-03 17:34 UTC by Marty Shannon
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHSA-2005-395
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:37:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stdout/stderr with -Dall (374.77 KB, text/plain)
2005-04-07 13:56 UTC, Marty Shannon
no flags Details
snmpd core file (5.1.2-11 x86) (3.63 MB, application/octet-stream)
2005-04-07 13:59 UTC, Marty Shannon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2005:395 qe-ready SHIPPED_LIVE Low: net-snmp security update 2005-10-05 04:00:00 UTC

Description Marty Shannon 2005-03-03 17:34:17 UTC
Description of problem:
manual invocation of "/etc/init.d/snmpd start" results in messages
claiming successful start in both /var/log/messages and
/var/log/boot.log, but a "ps ax" moments later shows no trace of the
process.

Version-Release number of selected component (if applicable):
5.1.2-11

How reproducible:
completely

Steps to Reproduce:
1. install net-snmpd
2. /etc/init.d/snmpd start
3. ps ax | grep snmp
  
Actual results:
snmpd process has exited

Expected results:
snmpd process listening for requests

Additional info:
after debugging this for a while, it seems to choke on reading
/usr/share/snmp/mibs/SNMP-VIEW-BASED-ACM-MIB.txt, but without any
diagnostic.

Comment 1 Marty Shannon 2005-03-03 18:50:14 UTC
using strace, it gets a SIGSEGV shortly after "init_usm(): snmpusm.c,
2661:", then registering callbacks, and the last act is
"read_premib_configs(): read_config.c, 814:".

The reference above to SNMP-VIEW-BASED-ACM-MIB is probably spurious,
but I can't tell for sure.

Comment 2 Marty Shannon 2005-03-03 18:54:54 UTC
Forgot to add: the last call to open() is:

open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 9


Comment 3 Radek Vokal 2005-03-05 11:57:08 UTC
Just to prove my thoughts, do you have SELinux turned on?

Comment 4 Marty Shannon 2005-03-05 16:55:43 UTC
SELinux is in "warn" mode.

Comment 5 Radek Vokal 2005-03-08 08:52:45 UTC
This is really strange, I've tested net-snmp on fresh RHEL-4AS machine
(i386) with SELinux in Permissive mode and it works fine. Starting it
as a service, quering all values, nothing causes a crash. I've even
tried removing the proposed file if this would cause an error but
still no luck. May I also have you snmpd.conf file, do you have there
something specific? On which architecture are you running the snmp
deamon? 

Comment 6 Bradley 2005-03-20 23:41:05 UTC
its lm sensors - unloading the lm_sensors kernel modules fixes this. See bug 151040

Comment 7 Marty Shannon 2005-04-07 13:56:48 UTC
Created attachment 112805 [details]
stdout/stderr with -Dall

Comment 8 Marty Shannon 2005-04-07 13:59:04 UTC
Created attachment 112806 [details]
snmpd core file (5.1.2-11 x86)

Comment 9 Marty Shannon 2005-04-07 14:02:02 UTC
Comment #6 is correct.  Removing the eeprom and i2c_* modules enables proper
startup.  Attachments (comments 7 & 8) show the failure mode.

Comment 10 Radek Vokal 2005-04-20 13:03:26 UTC
Fix is ready, will come out with new update

Comment 13 Radek Vokal 2005-06-24 08:12:02 UTC
*** Bug 161492 has been marked as a duplicate of this bug. ***

Comment 14 Douglas E. Warner 2005-08-04 18:34:40 UTC
I didn't see this get pushed out with the 4U1 update; is net-snmp going to be 
updated b/c of this issue? 
See: 
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/release-notes/as-x86/RELEASE-NOTES-U1-x86-en.html 

Comment 15 Radek Vokal 2005-08-05 06:05:28 UTC
The update fixing this issue is scheduled for U2. 

Comment 16 Red Hat Bugzilla 2005-10-05 12:37:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2005-395.html



Note You need to log in before you can comment on or make changes to this bug.