Bug 150205 - Unable to change RHN registration of an RHEL3 system
Summary: Unable to change RHN registration of an RHEL3 system
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Max Spevack
URL: not applicable
Whiteboard:
Keywords:
Depends On:
Blocks: 147875
TreeView+ depends on / blocked
 
Reported: 2005-03-03 18:52 UTC by Need Real Name
Modified: 2007-10-24 02:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 21:26:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2005-03-03 18:52:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
I need to move the RHN subscription of a machine from one RHN account to another.
Here are the steps that I used to do this:

  - remove system from old RHN account
  - rename /etc/sysconfig/rhn/systemid to /etc/sysconfig/rhn/systemid.orig
  - run up2date
  - at Red Hat Login screen:
    - say "use existing account"
    - enter new account name and password

At this point, up2date fails with this message:

The server indicated an error:

Error Class Code: 3
Error Class Info: This username is already taken, or the password is incorrect.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


The account name and password are verified to work via an RHN web login.  It is not letting me change the RHN registration of this machine.

Version-Release number of selected component (if applicable):
up2date-4.2.57-2, up2date-gnome-4.2.57-2, rhnlib-1.8-6.p22, rhn-applet-2.1.18-4

How reproducible:
Always

Steps to Reproduce:
See above
  

Actual Results:  Error message, every time.

Expected Results:  I should have been able to register the system with the new RHN account.

Additional info:

Comment 2 Adrian Likins 2005-06-14 20:45:01 UTC
So far, I haven't been able to reproduce, but I'm taking a look...

Comment 3 Mihai Ibanescu 2005-07-26 21:26:45 UTC
Closing, we were unable to reproduce it, and it's the only bug report I've
heard. Please reopen if the problem persists and you have more data.


Note You need to log in before you can comment on or make changes to this bug.