Bug 150206 - Cannot install with kickstart to already-existing LVM volume group
Summary: Cannot install with kickstart to already-existing LVM volume group
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-03 19:01 UTC by Stephen Tweedie
Modified: 2008-12-10 21:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 18:56:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file (1.49 KB, text/plain)
2005-03-03 19:03 UTC, Stephen Tweedie
no flags Details
Anaconda dump file (66.28 KB, application/octet-stream)
2005-03-03 19:04 UTC, Stephen Tweedie
no flags Details

Description Stephen Tweedie 2005-03-03 19:01:52 UTC
Description of problem:
I'm trying to automate the install of RHEL images to a test box via LVM.  All is
fine if anaconda is completely in charge of the entire LVM setup, but things
fall apart if you attempt to install to a new logical volume on an existing
volume group.

Version-Release number of selected component (if applicable):
RHEL-4 GA

How reproducible:
100%

Steps to Reproduce:
1. Install to a volume group
2. Install a second image using the attached kickstart file
  
Actual results:
Anaconda dump (attached) while setting up filesystems.

Expected results:
Install.

Additional info:
The partitioning setup that is causing trouble is:

partition /boot --fstype=ext3 --noformat --onpart=/dev/sda5
 
volgroup --noformat shard
logvol / --fstype ext3 --name=i686-rhel4 --vgname=shard --size=8000
logvol swap --fstype swap --name=swap --vgname=shard --size=4000

The /dev/sda5 partition has already been created.  The "shard" volume group
already exists, and "--noformat" is documented as meaning "Use an existing
volume group and don't format it."

Comment 1 Stephen Tweedie 2005-03-03 19:03:27 UTC
Created attachment 111626 [details]
Kickstart file

Comment 2 Stephen Tweedie 2005-03-03 19:04:25 UTC
Created attachment 111627 [details]
Anaconda dump file

Comment 3 kmself 2005-08-23 00:36:06 UTC
This bug is specifically applicable to creating installs to be used as virtual
hosts, eg:  under Xen.

Falling back to creating an install image externally then copying it to an LVM.

Comment 4 Chris Lumens 2008-07-25 17:18:24 UTC
A lame response, but is this fixed in an update release of RHEL4, or perhaps
even in RHEL5?  It's been quite a while since RHEL4 GA and we've fixed a ton of
bugs since then.

Comment 5 Chris Lumens 2008-12-10 18:56:04 UTC
Stephen - It seems to me like this one probably ought to be fixed by now at least in RHEL5, though I do not know for sure.  The state of the lvm bugs is kind of a mess.  For now I'm going to close this as WORKSFORME, but feel free to reopen this against RHEL5 if you are continuing to see problems.  Thanks.

Comment 6 Stephen Tweedie 2008-12-10 21:21:01 UTC
It's conceivable that it has been fixed.  But the installs I've done recently have all been from the anaconda GUI, not from kickstart, it's quite possible I'd not have noticed if the bug were still there.

I'll certainly reopen if I see it recur.


Note You need to log in before you can comment on or make changes to this bug.