Bug 150220 - intel e100 driver drops out regularly
intel e100 driver drops out regularly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 15:26 EST by Remco Poelstra
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 13:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kernel log of a e100 drop out (1.54 KB, text/plain)
2005-03-03 15:29 EST, Remco Poelstra
no flags Details
kernel log of an e100 driver crash (2.26 KB, text/plain)
2005-05-11 22:21 EDT, Henning Hogue
no flags Details
Output of lsmod and dmesg command (16.14 KB, text/plain)
2005-10-31 08:22 EST, Remco Poelstra
no flags Details

  None (edit)
Description Remco Poelstra 2005-03-03 15:26:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
Regularly the e100 driver stops functioning. The NETDEV WATCHDOG has
to come in and reset the driver/card.
It seems to behave correct under Windows 2k. Also does it seems to
behave correct when connected to a 100Mbit/Full-duplex line. I'm
usally on 10Mbit/Half-duplex.
I've had this problem before years ago (+-3 year), but then the
problem was solved by using the e100 driver instead of the eepro100.
At this moment the eepro100 doesn't work at all and constantly gives
wait_for_cmd_done timeout errors.


Version-Release number of selected component (if applicable):
2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot the machine
2. Do some network related activity
3. Wait a while, sometimes it takes longer than other times before it
starts.
4. The card stops functioning and a few seconds later it's resetten by
the kernel and it works again.

    

Actual Results:  A temporary loss of connection

Expected Results:  No loss of connection

Additional info:

Toshiba satellite pro 4600
intel etherexpress 100
Comment 1 Remco Poelstra 2005-03-03 15:29:39 EST
Created attachment 111636 [details]
Kernel log of a e100 drop out
Comment 2 Henning Hogue 2005-05-11 22:19:53 EDT
I believe that I am experiancing a similar bug. When attempting to play a mythtv
recording from a remote machine the e100 driver will crash. The differenct
appears to be that the network does not work after the network watchdog brings
it back up. 
The machine is a Toshiba satellite 2805-s402 and the network card is a intel
etherexpress 100
Comment 3 Henning Hogue 2005-05-11 22:21:46 EDT
Created attachment 114277 [details]
kernel log of an e100 driver crash
Comment 4 Dave Jones 2005-07-15 15:10:06 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Remco Poelstra 2005-07-27 11:39:08 EDT
The problem had somewhat faded to a less-frequent case lately. With this new
kernel it seems to have dissapeared.
If it comes back, then I will let you know.
I'm in the planning of installing FC4, so I'll update this record appropriately
then.
Comment 6 Remco Poelstra 2005-07-28 06:21:30 EDT
Seems I was just a few hours to early. It just droppped out again. Leaving only
the following message:
kernel: e100: eth0: e100_watchdog: link up, 10Mbps, half-duplex
I'm sorry for any inconvinience from my last post.
Comment 7 Igor S. Pelykh 2005-10-30 09:32:52 EST
Maybe bad device? Or trable at "sleep mode". I have same device, but have not
problems with it.
Comment 8 Dan Carpenter 2005-10-30 11:10:32 EST
Could you post the output from `lsmod` and a complete `dmesg -s`?

Comment 9 Remco Poelstra 2005-10-31 08:22:19 EST
Created attachment 120562 [details]
Output of lsmod and dmesg command
Comment 10 Remco Poelstra 2005-10-31 08:24:19 EST
Per request I've updated to version fieldto FC4, since I'm running FC4 now and
the problem has remained.
Comment 11 Dan Carpenter 2005-11-01 15:30:42 EST
I think you may have a similar issue as bug 172067.  Everyone affected by this
seems to be using toshiba satellite notebooks.  

Could you try the `echo 3 >/proc/acpi/sleep` and wake to reproduce the bug?

I don't necessarily advise people to try the rmmod trick from 172067.  I've
corrupted my filesystem before by rmmodding network drivers and modprobing new
versions.

Comment 12 Remco Poelstra 2005-11-01 17:18:23 EST
Tried the echo trick, but ethernet works fine before and after that. I'll try
some mouse movement when the card malfunctions. All I got was a nice kernel
stacktrace for an illegal context in slab.c.
Comment 13 Dave Jones 2005-11-10 16:54:29 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 14 John W. Linville 2005-12-08 13:29:40 EST
Closed due to lack of response.  Please reopen when the requested information  
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.