Bug 1502233 - Chromium dark theme compatibility regression
Summary: Chromium dark theme compatibility regression
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-15 11:08 UTC by Edward O
Modified: 2018-01-01 22:09 UTC (History)
4 users (show)

Fixed In Version: chromium-62.0.3202.89-1.fc27 chromium-63.0.3239.108-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-01 22:09:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
chromium is buggy but chrome is fine (94.24 KB, image/png)
2017-10-15 11:08 UTC, Edward O
no flags Details

Description Edward O 2017-10-15 11:08:28 UTC
Created attachment 1338800 [details]
chromium is buggy but chrome is fine

Description of problem:
Chromium does not display correctly with global gnome dark theme enabled. Chrome does (see screenshot).
I also don't remember having this issue in Fedora 26, so it may be a regression.

Version-Release number of selected component (if applicable):
* gnome-shell-3.26.1-1.fc27
* chromium-61.0.3163.100-1.fc27 (updates-testing repo)
* google-chrome-stable-61.0.3163.100-1.x86_64 (google-chrome repo)

How reproducible:


Steps to Reproduce:
1. Enable dark theme in gnome tweaks
2. Open chromium
3. Open any dialog e.g. try to bookmark with Ctrl-D
4. Install chrome from google rpm or repository ( https://www.if-not-true-then-false.com/2010/install-google-chrome-with-yum-on-fedora-red-hat-rhel/ )

Actual results:
2. Chromium is white instead of dark
3. Unreadable dialogs
4. Chrome is fine

Expected results:
2. Chrome

Additional info:
Gnome 3.26 on X11

Comment 1 Edward O 2017-10-15 11:10:17 UTC
To finish:
Expected results:
2. Chromium window decorations are dark
3. Dialogs are readable i.e. light text on dark background

Comment 2 Tomas Popela 2017-10-16 04:53:09 UTC
I think that enabling the gtk3 support would solve the problem here (Chromium will then behave like Chrome).. Tom, can we enable it? I see that you turn the gtk3 support off, when Chromium started to build it by default, but that was over a year ago and official Chrome package is using gtk3 by default and there were a lot of fixes there (regarding to the reasons why it was turned off)

Comment 3 Fedora Update System 2017-11-06 16:33:29 UTC
chromium-62.0.3202.75-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c11dd42cc2

Comment 4 Tom "spot" Callaway 2017-11-06 16:33:37 UTC
I have enabled gtk3 support in the 62 build headed to updates.

Comment 5 Fedora Update System 2017-11-06 16:33:51 UTC
chromium-62.0.3202.75-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5b5eb98196

Comment 6 Fedora Update System 2017-11-06 16:34:10 UTC
chromium-62.0.3202.75-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8c90ecaf36

Comment 7 Fedora Update System 2017-11-06 21:16:05 UTC
chromium-62.0.3202.75-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c11dd42cc2

Comment 8 Fedora Update System 2017-11-06 23:46:34 UTC
chromium-62.0.3202.75-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8c90ecaf36

Comment 9 Fedora Update System 2017-11-07 00:12:48 UTC
chromium-62.0.3202.75-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5b5eb98196

Comment 10 Fedora Update System 2017-11-09 19:47:42 UTC
chromium-62.0.3202.89-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f2f3fa09e3

Comment 11 Fedora Update System 2017-11-09 19:48:09 UTC
chromium-62.0.3202.89-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f87ce166c5

Comment 12 Fedora Update System 2017-11-09 19:48:34 UTC
chromium-62.0.3202.89-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e5bbb657c5

Comment 13 Fedora Update System 2017-11-11 16:02:57 UTC
chromium-62.0.3202.89-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e5bbb657c5

Comment 14 Fedora Update System 2017-11-11 17:30:31 UTC
chromium-62.0.3202.89-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f87ce166c5

Comment 15 Fedora Update System 2017-11-12 02:40:02 UTC
chromium-62.0.3202.89-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f2f3fa09e3

Comment 16 Tom "spot" Callaway 2017-11-13 17:39:51 UTC
Testing with chromium-62.0.3202.89 and this problem seems to be resolved. Chromium honors the gnome theme changes and there are no more white on white issues.

Comment 17 Fedora Update System 2017-11-15 17:53:03 UTC
chromium-62.0.3202.89-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Edward O 2017-11-15 23:35:18 UTC
Confirmed working after upgrading to test version with
# dnf upgrade chromium\*  --enablerepo=updates-testing

Thanks!

Comment 19 Fedora Update System 2017-12-18 09:13:37 UTC
chromium-63.0.3239.108-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ea44f172e3

Comment 20 Fedora Update System 2017-12-18 22:39:57 UTC
chromium-63.0.3239.108-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ea44f172e3

Comment 21 Fedora Update System 2018-01-01 22:09:41 UTC
chromium-63.0.3239.108-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.