Bug 1502283 - SELinux is preventing php-fpm from 'map' accesses on the file /home/mikhail/www/ex1/index.php.
SELinux is preventing php-fpm from 'map' accesses on the file /home/mikhail/w...
Status: CLOSED DUPLICATE of bug 1494852
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
27
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:6c654204ef1b6f1cdeb898ec0d6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-15 10:08 EDT by Mikhail
Modified: 2017-10-17 06:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-17 06:30:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2017-10-15 10:08:40 EDT
Description of problem:
SELinux is preventing php-fpm from 'map' accesses on the file /home/mikhail/www/ex1/index.php.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that php-fpm should be allowed map access on the index.php file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'php-fpm' --raw | audit2allow -M my-phpfpm
# semodule -X 300 -i my-phpfpm.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                unconfined_u:object_r:httpd_user_content_t:s0
Target Objects                /home/mikhail/www/ex1/index.php [ file ]
Source                        php-fpm
Source Path                   php-fpm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-283.10.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.13.6-300.fc27.x86_64+debug #1
                              SMP Thu Oct 12 15:48:26 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-10-15 19:07:21 +05
Last Seen                     2017-10-15 19:07:21 +05
Local ID                      80944a24-16e4-49ad-b78e-cb93716a68a5

Raw Audit Messages
type=AVC msg=audit(1508076441.312:2099): avc:  denied  { map } for  pid=21394 comm="php-fpm" path="/home/mikhail/www/ex1/index.php" dev="sdb" ino=6599384663 scontext=system_u:system_r:httpd_t:s0 tcontext=unconfined_u:object_r:httpd_user_content_t:s0 tclass=file permissive=1


Hash: php-fpm,httpd_t,httpd_user_content_t,file,map

Version-Release number of selected component:
selinux-policy-3.13.1-283.10.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.2
hashmarkername: setroubleshoot
kernel:         4.13.6-300.fc27.x86_64+debug
type:           libreport

Potential duplicate: bug 1494852
Comment 1 Lukas Vrabec 2017-10-17 06:30:48 EDT

*** This bug has been marked as a duplicate of bug 1494852 ***

Note You need to log in before you can comment on or make changes to this bug.