Bug 150248 - memory leak using vfork/execve on AS/ES 3.0
memory leak using vfork/execve on AS/ES 3.0
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 17:25 EST by Isabel Lin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-23 05:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Isabel Lin 2005-03-03 17:25:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
    I have a multi-threaded program that uses vfork/execve to execute commands. The program is compiled on AS 2.1 using gcc-3.0.4. When the program is run on  AS 2.1 with glibc-2.2.4-26, no memory leak is reported using "top". If the program is run on AS 3.0 or ES 3.0 with glibc-2.3.2-95.3, then I see RSS keep incrementing by 4K using "top". The same program, if compiled on AS 3.0 using gcc-3.2.3, does not report any memory leak.
    Is this a known issue? What should I do to compile the program once on AS 2.1 to be able to resolve the memory leak issue on 3.0? 


Version-Release number of selected component (if applicable):
glibc-2.3.2-95.3

How reproducible:
Always

Steps to Reproduce:
1. How do I attach my compiled program?
2.
3.
  

Additional info:
Comment 1 Jakub Jelinek 2005-03-04 06:20:21 EST
No, this is not know.  Can you create a small self-contained testcase?
BTW, 2.3.2-95.3 is really old, current RHEL3 glibc is -95.30 and contains many
bugfixes since the original RHEL3 GA glibc.
Comment 2 Jakub Jelinek 2005-05-02 05:27:09 EDT
Without that information we really can't move forward.
You can just use "Create a New Attachment" to add the attachment, or if that
doesn't work for you for whatever reason, you can just mail it to me.

If there is no response soon, I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.